Bug 1254670 - targetcli persistent reservation: PR out (Register): Not ready
targetcli persistent reservation: PR out (Register): Not ready
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-rtslib (Show other bugs)
7.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Andy Grover
Storage QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 11:44 EDT by Martin Hoyer
Modified: 2015-11-19 08:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 08:23:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Hoyer 2015-08-18 11:44:25 EDT
Description of problem:
During our regression tests on RHEL-7.2, we found out that there is a problem while running SCSI PERSISTENT RESERVE OUT command on iSCSI multipath device. 

This issue was not present in RHEL-7.1


# sg_persist --out --register --param-sark=123abc /dev/mapper/mpatha
  LIO-ORG   target1-tpg1-lu   4.0
  Peripheral device type: disk
PR out (Register): Not ready
Return:2


Version-Release number of selected component (if applicable):
3.10.0-302.el7.x86_64
targetcli-2.1.fb41-2.el7.noarch
iscsi-initiator-utils-6.2.0.873-32.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Establish iSCSI session with targetcli target
2. Run multipath on it
3. Run: sg_persist --out --register --param-sark=123abc /dev/mapper/mpathX

Actual results:
  LIO-ORG   target1-tpg1-lu   4.0
  Peripheral device type: disk
PR out (Register): Not ready
Return:2

Expected results:
  LIO-ORG   target1-tpg1-lu   4.0
  Peripheral device type: disk
Return:0
Comment 3 Andy Grover 2015-08-18 12:13:53 EDT
only happens with multipath?
Comment 4 Andy Grover 2015-08-18 13:43:01 EDT
Something to try: verify /var/target/pr/ directory exists, and if not, if creating it fixes things. Thanks.
Comment 5 Martin Hoyer 2015-08-19 04:41:27 EDT
Creating /var/target/pr/ directory fixed the problem.

Multipath is not relevant. Happens also without it.
Comment 8 Martin Hoyer 2015-08-31 08:16:35 EDT
Fixed in python-rtslib-2.1.fb57-2.el7
Comment 9 errata-xmlrpc 2015-11-19 08:23:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2439.html

Note You need to log in before you can comment on or make changes to this bug.