Bug 1254696 - jettison.jar is empty
jettison.jar is empty
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jettison (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Simacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1251194
  Show dependency treegraph
 
Reported: 2015-08-18 12:45 EDT by gil cattaneo
Modified: 2015-08-18 14:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.3.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-18 14:06:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jettison.jar (6.23 KB, application/zip)
2015-08-18 12:46 EDT, gil cattaneo
no flags Details

  None (edit)
Description gil cattaneo 2015-08-18 12:45:07 EDT

    
Comment 2 gil cattaneo 2015-08-18 12:59:47 EDT
Seem maven-bundle-plugin have a bad configration, because generate an empty artifact.
Please, change with:
%pom_remove_plugin :maven-bundle-plugin
%pom_add_plugin org.apache.felix:maven-bundle-plugin:2.5.4 . '
<extensions>true</extensions>
<configuration>
  <instructions>
    <Bundle-Name>${project.artifactId}</Bundle-Name>
    <Bundle-SymbolicName>${project.groupId}.${project.artifactId}</Bundle-SymbolicName>
    <Export-Package>org.codehaus.jettison*;version=${project.version}</Export-Package>
    <Import-Package>*</Import-Package>
    <Implementation-Title>${project.name}</Implementation-Title>
    <Implementation-Version>${project.version}</Implementation-Version>
  </instructions>
</configuration>'
Comment 3 Michael Simacek 2015-08-18 14:06:56 EDT
jettison-1.3.7-2 should now be available in rawhide

Note You need to log in before you can comment on or make changes to this bug.