Bug 1254713 - VM stuck in down state on vdsm when powering off VM with port mirroring
VM stuck in down state on vdsm when powering off VM with port mirroring
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.0
x86_64 Linux
high Severity high
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Marcin Mirecki
Meni Yakove
: Automation, Regression
: 1255106 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 13:30 EDT by Meni Yakove
Modified: 2016-04-19 21:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:26:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: Triaged+


Attachments (Terms of Use)
vdsm, supervdsm and engine logs (255.18 KB, application/zip)
2015-08-18 13:30 EDT, Meni Yakove
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45344 master MERGED virt: vm with port mirroring stuck in down state Never
oVirt gerrit 46394 ovirt-3.6 MERGED virt: vm with port mirroring stuck in down state Never

  None (edit)
Description Meni Yakove 2015-08-18 13:30:05 EDT
Description of problem:
When powering off VM with port mirroring enabled the VM id down in the UI but stuck in down state in vdsm
vdsClient -s 0 list table
ea37ce01-3203-44b9-8f87-36e5550a23b7   3458  golden_env_mixed_virtio_0 Down

When running vdsClient -s 0 destroy ea37ce01-3203-44b9-8f87-36e5550a23b7 we get error Unexpected exception
Thread-281::ERROR::2015-08-18 20:22:55,031::__init__::527::jsonrpc.JsonRpcServer::(_serveRequest) Internal server error
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yajsonrpc/__init__.py", line 522, in _serveRequest
    res = method(**params)
  File "/usr/share/vdsm/rpc/Bridge.py", line 277, in _dynamicMethod
    result = fn(*methodArgs)
  File "/usr/share/vdsm/API.py", line 337, in destroy
    res = v.destroy()
  File "/usr/share/vdsm/virt/vm.py", line 3757, in destroy
    result = self.doDestroy()
  File "/usr/share/vdsm/virt/vm.py", line 3775, in doDestroy
    return self.releaseVm()
  File "/usr/share/vdsm/virt/vm.py", line 3675, in releaseVm
    supervdsm.getProxy().unsetPortMirroring(network, nic.name)
  File "/usr/share/vdsm/supervdsm.py", line 50, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 48, in <lambda>
    **kwargs)
  File "<string>", line 2, in unsetPortMirroring
  File "/usr/lib64/python2.7/multiprocessing/managers.py", line 773, in _callmethod
    raise convert_to_error(kind, result)
TrafficControlException: (22, 'RTNETLINK answers: Invalid argument', ['/usr/sbin/tc', 'qdisc', 'del', 'dev', u'ovirtmgmt', 'ingress'])


The VM cannot run again on this host untill I reboot the host


Version-Release number of selected component (if applicable):
vdsm-4.17.2-1.el7ev.noarch
rhevm-3.6.0-0.11.master.el6.noarch


Steps to Reproduce:
1. Create VM 
2. Create vNIC profile with port mirroring for ovirtmgmt network
3. Select the vNIC profile with the port mirroring for the VM
4. Start the VM
5. Power off the VM

Actual results:
VM is stuck in VDSM

Expected results:
VM is not stuck in VDSM
Comment 1 Meni Yakove 2015-08-18 13:30:42 EDT
Created attachment 1064383 [details]
vdsm, supervdsm and engine logs
Comment 3 Michael Burman 2015-08-20 02:27:43 EDT
*** Bug 1255106 has been marked as a duplicate of this bug. ***
Comment 4 Michael Burman 2015-10-06 08:04:49 EDT
Verified on - 3.6.0-0.18.el6 with vdsm-4.17.8-1.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.