Bug 1254729 - abrt-applet fails to load: pango_fc_... undefined
abrt-applet fails to load: pango_fc_... undefined
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 13:45 EDT by Peter Trenholme
Modified: 2015-08-20 18:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-20 18:52:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2015-08-18 13:45:25 EDT
Description of problem: Most gtk-dependent applications fail to load "abrt-applet" is a typical example, not the cause.

$ abrt-applet 
abrt-applet: symbol lookup error: /lib64/libgtk-3.so.0: undefined symbol: pango_fc_font_map_config_changed

Version-Release number of selected component (if applicable): Latest rawhide

How reproducible: every time

Steps to Reproduce: See description, above

Actual results: See description, above

Expected results: No error

Additional info:
THIS SEEMS TO BE A GENERIC (pango library?) PROBLEM.

From the following, I infer that the pango library has been subdivided into various "parts," but dependency on those parts were neglected when the pango library was simplified and the update rpm posted. In fact, a :dnf provides ..." for those libraries returns a "not found."

/sbin/ldconfig: File /lib64/libpangocairo-1.0.so.0.3703.0 is empty, not checked.
/sbin/ldconfig: File /lib64/libpangoxft-1.0.so.0.3703.0 is empty, not checked.
/sbin/ldconfig: File /lib64/libpangocairo-1.0.so is empty, not checked.
/sbin/ldconfig: File /lib64/libpangoft2-1.0.so.0.3703.0 is empty, not checked.
/sbin/ldconfig: File /lib64/libpangoft2-1.0.so is empty, not checked.
/sbin/ldconfig: File /lib64/libpango-1.0.so.0.3703.0 is empty, not checked.
/sbin/ldconfig: File /lib64/libpango-1.0.so is empty, not checked.
/sbin/ldconfig: File /lib64/libpangoxft-1.0.so is empty, not checked.
Comment 1 Jakub Filak 2015-08-19 09:41:54 EDT
Thank you for the report. I am not able to reproduce the problem. 

The symbol "pango_fc_font_map_config_changed" is provided by the "/usr/lib64/libpangoft2-1.0.so" file.

$ readelf -s --wide /usr/lib64/libpangoft2-1.0.so | grep pango_fc_font_map_config_changed

the library is required by libpangocairo:
$ readelf -d /usr/lib64/libpangocairo-1.0.so | grep libpangoft2

and libpangocairo is required by abrt-applet:
$ readelf -d /usr/bin/abrt-applet | grep libpangocairo


Can you please try to reinstall the package pango, re-test and report the results here:
# dnf reinstall pango
Comment 2 Peter Trenholme 2015-08-20 18:52:51 EDT
that fixed it. Thanks. (I thought I'd done that, but it looks like I didn't. Sorry.)

Note You need to log in before you can comment on or make changes to this bug.