Bug 1254785 - ipa-client-install does not properly handle dual stacked hosts
ipa-client-install does not properly handle dual stacked hosts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Pavel Picka
Namita Soman
:
Depends On: 1206565
Blocks: 1014845
  Show dependency treegraph
 
Reported: 2015-08-18 17:01 EDT by Martin Bašti
Modified: 2015-11-19 07:05 EST (History)
4 users (show)

See Also:
Fixed In Version: ipa-4.2.0-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:05:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (7.53 KB, text/plain)
2015-10-13 15:03 EDT, Pavel Picka
no flags Details

  None (edit)
Description Martin Bašti 2015-08-18 17:01:28 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/4249

Ticket was cloned from Red Hat Bugzilla (product ''Fedora''): [https://bugzilla.redhat.com/show_bug.cgi?id=1076262 Bug 1076262]

{{{
Description of problem:
Joining a host to a freeipa domain never creates AAAA records if dual stacked,
and in a pure IPv6 environment there are many other issues: for example,
service checks seem to only check if a name is resolveable on A records.
Finally, even once joined, dns record updates don't (seem) to create or update
AAAA records on the domain network.

1) ipa-join should be able to handle
* v4 only
* v4 and v6 (Uploading both A and AAAA records and PTRs)
* v6 only
2) service checks should check both A and AAAA and provided *one* of these
exists it should validate.

In general, I think that freeipa needs more ipv6-only network testing ....

Version-Release number of selected component (if applicable):
freeipa-3.3.4
}}}

Related bug for ipa-server-install: #3575
Comment 5 Pavel Picka 2015-10-13 15:03 EDT
Created attachment 1082612 [details]
log

Verified

4.2.0-13
Comment 6 errata-xmlrpc 2015-11-19 07:05:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.