Bug 1254793 - Network Server Web Interface Not Able to Register SUT
Network Server Web Interface Not Able to Register SUT
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware (Show other bugs)
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: brose
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2015-08-18 17:14 EDT by HP Enterprise Cert team
Modified: 2017-04-22 22:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-04-22 22:25:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot of error (89.99 KB, image/jpeg)
2015-08-18 17:14 EDT, HP Enterprise Cert team
no flags Details
network server kickstart file (7.11 KB, text/plain)
2015-08-18 17:17 EDT, HP Enterprise Cert team
no flags Details
screenshot2.jpg (94.33 KB, image/jpeg)
2015-08-18 18:37 EDT, HP Enterprise Cert team
no flags Details
screenshot3.jpg (86.14 KB, image/jpeg)
2015-08-18 18:50 EDT, HP Enterprise Cert team
no flags Details
registerip.jpg (68.71 KB, image/jpeg)
2015-08-25 17:29 EDT, HP Enterprise Cert team
no flags Details
registerip2.jpg (74.54 KB, image/jpeg)
2015-08-25 17:55 EDT, HP Enterprise Cert team
no flags Details

  None (edit)
Description HP Enterprise Cert team 2015-08-18 17:14:32 EDT
Created attachment 1064506 [details]
screenshot of error

Description of problem:
On the network test server web interface configuration tab not able to successfully register the RHEL7.0 SUT. Error encountered is could not reach sut1.localdomain. Yet from the network test server I can successfully ping sut1.localdomain.
Per Gary Case the network test server is running RHEL7.1 and was installed using the attached kickstart file rhcert-rhel7-kickstart.cfg.
The SUT is running RHEL7.0.

Version-Release number of selected component (if applicable):
Cert kit components on SUT & Network Server:

Also tried redhat-certification-1.0-20150723.el7.noarch

How reproducible: always

Steps to Reproduce:
1. On the network test server install RHEL7.1 using attached kickstart 
2. Ensure only one NIC port has an ip address
3. Set a unique hostname
4. Install above cert kit components
5. Disable firewall - systemctl stop firewalld
6. Activate network server - rhcert-backend server start
7. On network server open firefox and enter network server URL, see attached
   screenshot which includes error

Actual results: Firefox error - could not reach sut1.localdomain, see attached screenshot. Yet from the network test server I can successfully ping sut1.localdomain. Also from the SUT I can successfully ping the network server markrs.localdomain.

Expected results: Registering the SUT via the network server web interface should work.

Additional info: Only way I have been able to register a SUT is the following:
1. Network server set SELinux to permissive
2. On the SUT run command - rhcert-backend register --server markrs.localdomain
3. Refresh web interface on network server
Comment 1 HP Enterprise Cert team 2015-08-18 17:17:00 EDT
Created attachment 1064507 [details]
network server kickstart file
Comment 2 HP Enterprise Cert team 2015-08-18 18:36:59 EDT
Additional details when registering SUT via the alternate method, step 2 above.

When the SUT command rhcert-backend register --server markrs.localdomain is run the SUT output is in the attached screenshot2.jpg.
Once the network server browser is refreshed the system is still listed as localhost.localdomain even though the SUT /etc/hostname is sut1.localdomain, see screenshot3.jpg.

The web interface system field always reporting localhost.localdomain prevents the SUT from downloading the pre-built VMs from the network server and also causes the network test to fail.
Comment 3 HP Enterprise Cert team 2015-08-18 18:37:35 EDT
Created attachment 1064557 [details]
Comment 4 HP Enterprise Cert team 2015-08-18 18:50:49 EDT
Created attachment 1064562 [details]
Comment 5 Greg Nichols 2015-08-18 20:41:00 EDT
I suspect the SUT isn't configured with the correct hostname.   What does the "hostname" command show from the SUT?   This would explain why the registration via the CLI from the SUT to the server result shows "localhost.localdomain".

Does registration from the server to the SUT via IP address work?   Try entering the IP address of the SUT in the server dialog that asks for hostname.

How is the SUT's hostname configured so that ping from the server translates the name to an IP address - hosts table on the server, or is DNS running?   Does ping from the server show IP address of the SUT (

Can testing proceede based on IP addresses, and avoid this problem alltogether?

Comment 6 HP Enterprise Cert team 2015-08-19 17:08:25 EDT

At the bottom of the SUT screenshot2.jpg, the hostname command returns sut1.localdomain as expected.

Registration via the SUT IP address fails with the same error... could not reach ip address.

For the hostname resolution I'm using the /etc/hosts file.
From the network server when I ping the SUT hostname it returns the SUT ip

Mark C.
Comment 7 Chris Tatman 2015-08-24 10:58:10 EDT
Hi Greg,

I thought we did away with the need for DNS and hostname registration? Many vendors do not have DNS setup in their labs. This looks like we might have reintroduced that bug?


Comment 8 Greg Nichols 2015-08-25 14:40:38 EDT
That's correct, DNS resolution is not required if IP addresses are used.

From screenshot 2, the SUT sees the server as

The SUT sees its hostname appears as "sut1.localdomain",
and the server markrs.localdomain.

The server sees the SUT as

The registration seems to work.

Screenshot 3 from markrs shows an SUT at, which it seems as "localhost.localdomain", which shows as "ready", again, seeming to work.

As a result, I'm not clear on the test setup.  Are there two SUT's, or ?

In any case, can we re-try testing based on IP address, just one SUT and a server?
Comment 9 HP Enterprise Cert team 2015-08-25 15:35:15 EDT

There is only one SUT but it has four ethernet ports, which is why you see multiple ips for the SUT. The network server has one active ethernet port at 
The problem is I have not been able to register the SUT via the network server web interface even when server names are resolved vi the /etc/hosts file.
Screenshot 2 is when registering using the SUT command and /etc/hosts name resolution.

I'll provide details when not using the /etc/hosts but rather ip addresses only as this is our prefered method.

Mark C.
Comment 10 HP Enterprise Cert team 2015-08-25 17:29:02 EDT
Created attachment 1066998 [details]
Comment 11 HP Enterprise Cert team 2015-08-25 17:54:52 EDT

The attached registerip.jpg error, waiting for connection, occurs when I try to register the DL360 Gen9 SUT at from the network server web interface using ip addressing only. The /etc/hosts is not being used here.
The DL360pGen8 is still listed in the configuration tab b/c I cannot remove it.

The registerip2.jpg is with the network server /etc/hostname as the ip address just to verify same outcome.

Mark C.
Comment 12 HP Enterprise Cert team 2015-08-25 17:55:21 EDT
Created attachment 1067013 [details]
Comment 13 Greg Nichols 2015-08-25 18:02:22 EDT
What does "rhcert-backend server status" show when run on

You could also try running the listener process on in the foreground via "rhcert-backend server listener" and look for logging of requests by the server (

Comment 14 HP Enterprise Cert team 2015-08-26 11:45:39 EDT

How do I remove a registered server with a status of waiting for response when the remove button does not work?
There is not a test plan associated with this particular SUT but I cannot delete it. I would like to start fresh, nothing listed under registered systems.
Comment 15 HP Enterprise Cert team 2015-08-26 16:45:53 EDT

In reference to comment 12 & 13, the SUT rhcert-backend server service was not running. Started it and set it to start at boot time. This resolved the server registration waiting for connection error, but the registration status remained in a waiting for response state until the SUT rhcert-backend server service was restarted again.
Comment 16 Chris Tatman 2015-09-10 09:51:19 EDT
Hi Greg,

How would you like to proceed next? For debug purposes, should HP try with only one ethernet port connected? Can they get you any other data?


Comment 17 HPE Server Cert 2015-10-12 15:31:42 EDT

The other issue mentioned in comment #15 is no longer seen with the latest cert kit 20150901.

Mark C.
Comment 18 Chris Tatman 2015-10-26 12:23:19 EDT
Hi HP,

This bug is a little confusing to me after reading it a couple times and it may be confusing to the assigned engineer as well.

So let's try and get a clear description of what the exact problem at this time is.

Is the originally described issue still persisting with the 20150901 package? Do you guys still have trouble getting the sut to register? 

To me, it looks like the remianing problem is that the rhcert-backend server service needs to be restarted multiple times before the SUT can register.

Is this an accurate description of what you are seeing now?

Comment 19 HPE Server Cert 2015-10-26 14:14:20 EDT

All issues mentioned in this bug have been resolved, the latest official cert kit 20150901 works fine for registering a SUT.

Mark C.

Note You need to log in before you can comment on or make changes to this bug.