Bug 1254805 - mate-terminal --title=foo does not set title to foo
mate-terminal --title=foo does not set title to foo
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mate-terminal (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 18:27 EDT by Ben Greear
Modified: 2015-08-31 23:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.10.2-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 23:36:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Greear 2015-08-18 18:27:25 EDT
Description of problem:

I have a script that launches a bunch of terminals to help get me
up and productive after a reboot.

But, with mate-terminal on Fedora 22, the --title option does not work:

mate-terminal --title=foo

(New terminal, but title is set to defaults).

Please make this work again!


Version-Release number of selected component (if applicable):

MATE Terminal 1.10.1

How reproducible:

Always

Steps to Reproduce:
1.

mate-terminal --title=foo

2.
3.

Actual results:

Title is user@host:dir

Expected results:

Title is 'foo'

Additional info:

There are several similar bugs for gnome-terminal.
Comment 1 Wolfgang Ulbrich 2015-08-18 18:50:59 EDT
Confirmed,
can you please open a report at upstream?
https://github.com/mate-desktop/mate-terminal
Comment 2 Wolfgang Ulbrich 2015-08-19 10:00:57 EDT
in edit -> profile preference -> second tab there is a drop-down-menu under title, change here to 'keep intial title'.
Than the default title is 'Terminal' or whatever you choose in your profile and you can change it with the -t option.

I'm thinking about to change this default behaviour for f23 with a gsettings override, but i can't do that in a release cycle, because it change the look and feel of mate-terminal.
Comment 3 Fedora Update System 2015-08-25 12:56:16 EDT
mate-desktop-1.10.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14264
Comment 4 Wolfgang Ulbrich 2015-08-25 13:17:12 EDT
Note, i did a gsettings override for f23 in result the steps from comment2 aren't need anymore. But i can't do that in a release cycle of a package.
Comment 5 Fedora Update System 2015-08-26 00:25:02 EDT
mate-desktop-1.10.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mate-desktop'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14264
Comment 6 Fedora Update System 2015-08-31 23:36:16 EDT
mate-desktop-1.10.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.