Bug 1254813 - [RFE] os-net-config should support setting up patches between bridges
[RFE] os-net-config should support setting up patches between bridges
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-net-config (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: RHOS Maint
Shai Revivo
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 18:56 EDT by Dan Sneddon
Modified: 2016-10-10 13:03 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-10 13:03:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 329539 None None None 2016-07-05 05:08 EDT

  None (edit)
Description Dan Sneddon 2015-08-18 18:56:29 EDT
Description of problem:
It would be a nice feature if we could create a bridge and then patch it to another bridge inside of os-net-config.

Version-Release number of selected component (if applicable):


Actual results:
We can create bridges in os-net-config, but we can't yet create patches between the bridges.

Expected results:
We should be able to patch between bridges.

Additional info:
This would be nice for the following use case:

A 3rd-party Neutron driver needs to create ports that are on br-ex, but not have them be cleaned up by the neutron-ovs-cleanup script. One way to do this is to create a second bridge, then patch between the two bridges. Since the ports are not on br-ex, the neutron script won't clean up those ports.
Comment 3 Mike Burns 2016-04-07 16:47:27 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Steven Hardy 2016-07-05 05:08:24 EDT
Dan mentioned this may be fixed by https://review.openstack.org/#/c/329539/
Comment 8 Dan Sneddon 2016-10-10 13:03:04 EDT
This was actually completed some time ago, there is now an OvsPatchPort object object in os-net-config.

Note You need to log in before you can comment on or make changes to this bug.