Bug 1254832 - [Docs] [Director] Inspecting the Hardware of Nodes, need section for inspecting one node at a time and mark it available manually
[Docs] [Director] Inspecting the Hardware of Nodes, need section for inspecti...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
Director
Unspecified Unspecified
medium Severity low
: z1
: 7.0 (Kilo)
Assigned To: Dan Macpherson
RHOS Documentation Team
: Documentation, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 21:12 EDT by chris alfonso
Modified: 2016-01-31 21:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-24 20:36:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris alfonso 2015-08-18 21:12:17 EDT
Description of problem:
Section 6.2.2  Inspecting the Hardware of Nodes should probably contain a subsection of how to inspect one node at a time instead of just a bulk start. The second part of that instruction should instruct the admin to mark the node as available manually, since that is only done automatically if the introspection was done in bulk.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Andrew Dahms 2015-08-20 21:52:50 EDT
Assigning to Dan for review.
Comment 5 Dan Macpherson 2015-09-24 22:53:33 EDT
Chris,

I've added the following to the Introspection procedure:

===
Alternatively, perform a single introspection on each node individually. Set the node to maintenance mode, perform the introspection, then revert the node out of maintenance mode:

$ ironic node-set-maintenance [NODE UUID] true
$ openstack baremetal introspection start [NODE UUID]
$ ironic node-set-maintenance [NODE UUID] false
===

Link: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Scenario_2_Using_the_CLI_to_Create_a_Basic_Overcloud.html#sect-Inspecting_the_Hardware_of_Nodes

Does this suit the requirements in this BZ? Did you have any further changes needed?
Comment 6 Dan Macpherson 2015-11-11 21:51:18 EST
Hi Chris, just following up on this bug. Does the new documentation suit what you're after?
Comment 7 Dan Macpherson 2016-01-24 20:36:06 EST
No response in several months. Closing this bug, but feel free to reopen if further changes are required.

Note You need to log in before you can comment on or make changes to this bug.