Bug 1254857 - Device.map didn't updated correctly when converting host on SATA/iSCSI to KVM server
Device.map didn't updated correctly when converting host on SATA/iSCSI to KVM...
Status: CLOSED DUPLICATE of bug 1253223
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.2
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
P2V
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 01:54 EDT by fwu
Modified: 2015-08-24 04:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 04:39:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The log file of on both iSCSI and SATA device (77.46 KB, application/zip)
2015-08-19 01:54 EDT, fwu
no flags Details
The log file of on SATA device, OS version rhel6.7-i386 (60.91 KB, application/zip)
2015-08-19 22:32 EDT, fwu
no flags Details

  None (edit)
Description fwu 2015-08-19 01:54:50 EDT
Created attachment 1064625 [details]
The log file of on both iSCSI and SATA device

Description of problem:
Device.map didn't updated correctly when converting rhel6.7-i386 host on SATA/iSCSI device to KVM server by virt-p2v

Version-Release number of selected component (if applicable):
virt-v2v-1.28.1-1.49.el7.x86_64
virt-p2v-1.28.1-1.49.el7-1.iso

How reproducible:
100%

Steps to Reproduce:
 1. Install rhel6.7-i386 on SATA storage
 2. Boot into rhel6.7-i386 and check disk info original of OS host as below:
  # cat /boot/grub/device.map
   # this device map was generated by anaconda
    (hd0)      /dev/sda

  # lsblk
   NAME    MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
   sda     253:0    0 149.1G  0  disk 
   └─sda1  253:1    0 141.6G  0  part  /
   └─sda2  253:2    0   7.5G  0  part  [SWAP]  

 3. Boot the source machine into virt-p2v and input the ip and password of conversion server.
 4. Convert rhel6.7-i386 SATA host to KVM server via virt-p2v client.
 5. After conversion, boot into rhel6.7-i386 guest and examine checkpoints on KVM server.
 6. Check disk info of rhel6.7-i386 guest on KVM server as below
   #cat /boot/grub/device.map
    # this device map was generated by anaconda
    (hd0)      /dev/sda
   #lsblk
    NAME   MAJ:MIN RM   SIZE  RO TYPE  MOUNTPOINT
    vda    253:0    0 149.1G  0  disk 
    └─vda1 253:1    0 141.6G  0  part  /
    └─vda2 253:2    0   7.5G  0  part  [SWAP]

Actual results:
Device.map of rhel6.7-i386 guest did not updated to vda.

Expected results:
Device.map of rhel6.7-i386 guest should be updated to vda.

Additional info:
Similar situation happens in iSCSI storage, steps are the same as described above.
Attatched is the log file of both SATA and iSCSI conversion.
Comment 2 Richard W.M. Jones 2015-08-19 11:13:27 EDT
There's something wrong with the SATA conversion log file.
It appears to be truncated, and it may be the log from a different
run of the program:

rhel6.7-32-SATA.zip -> virt-v2v-conversion-log.txt ends with:

virt-v2v: error: internal error: invalid argument: cannot find libvirt pool 
'/var/tmp': Storage pool not found: no storage pool with matching name 
'/var/tmp'

and is clearly not the log from a full conversion.

To debug this issue I really need to see the full conversion log file.
Comment 3 Richard W.M. Jones 2015-08-19 11:15:41 EDT
The iSCSI log shows the same problem as bug 1253223, so I'm going
to ignore that.
Comment 4 fwu 2015-08-19 22:32:47 EDT
Created attachment 1065068 [details]
The log file of on SATA device, OS version rhel6.7-i386
Comment 5 Richard W.M. Jones 2015-08-20 12:21:44 EDT
According to the log, device.map in the original guest had:

(hd0)      /dev/sdb

This contradicts the bug description, which says that the mapping
had /dev/sda.  Can you go back and check the bug description is correct
and also that the log file corresponds to the conversion.
Comment 6 tingting zheng 2015-08-21 05:12:03 EDT
(In reply to Richard W.M. Jones from comment #5)
> According to the log, device.map in the original guest had:
> 
> (hd0)      /dev/sdb
> 
> This contradicts the bug description, which says that the mapping
> had /dev/sda.  Can you go back and check the bug description is correct
> and also that the log file corresponds to the conversion.

I think wufan hit bug 1253223.

So wufan,would you pls check the orignial mapping in iscsi host?
I think it's better to attach full log from conversion of SATA host.
Comment 7 fwu 2015-08-24 04:06:09 EDT
The log was correct and the description was not. Previously, I installed my host using USB device. After conversion, the device.map didn't update correctly. The issue, as Tingting said, hits Bug 1253223.

Then I tried again, after reinstall the guest with DVD and make sure the device map of original host had:'(hd0)      /dev/sda', the conversion was a success.

From my perspective, the problem occurs in this bug duplicate with Bug 1253223.
Comment 8 Richard W.M. Jones 2015-08-24 04:39:14 EDT
Based on comment 7, this must be a duplicate of bug 1253223.

*** This bug has been marked as a duplicate of bug 1253223 ***

Note You need to log in before you can comment on or make changes to this bug.