Bug 125486 - airo MPI350 stopped working
airo MPI350 stopped working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: FC2Update
  Show dependency treegraph
 
Reported: 2004-06-07 19:15 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 02:47:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
airo-422.txt (12.09 KB, text/plain)
2004-06-07 19:17 EDT, Warren Togami
no flags Details
airo-397-working.txt (12.05 KB, text/plain)
2004-06-07 19:19 EDT, Warren Togami
no flags Details
reenable card reset when module is loaded (409 bytes, patch)
2004-06-08 13:49 EDT, Fabrice Bellet
no flags Details | Diff

  None (edit)
Description Warren Togami 2004-06-07 19:15:20 EDT
Description of problem:
The airo MPI350 in my IBM Thinkpad T41 laptop stopped working on my
laptop with recent rawhide kernels and the 5.00.x and latest 5.30.x
firmware versions.  The last RH kernel tested to work properly was
release 397.  After that point the "RFMON" fixes went into the kernel.
 notting however said that it works on his firmware right now.

Notting's Firmware
==================
Firmware Version: 5b00.08

Warren's Laptop with kernel-2.6.6-1.397
=======================================
[root@ibmlaptop eth0]# pwd
/proc/driver/aironet/eth0
[root@ibmlaptop eth0]# cat Status
Status: CFG ACT SYN LNK PRIV KEY WEP
Mode: 3bf
Signal Strength: 87
Signal Quality: 26
SSID: spacedog
AP:
Freq: 0
BitRate: 11mbs
Driver Version: airo.c 0.6 (Ben Reed & Javier Achirica)
Device: 350 Series
Manufacturer: Cisco Systems
Firmware Version: 5.00.03
Radio type: 2
Country: 0
Hardware Version: ff
Software Version: 500
Software Subversion: 3
Boot block version: 159

Note that this proc directory is empty on the 422 kernel for me. 
Attaching dmesg next.
Comment 1 Warren Togami 2004-06-07 19:17:12 EDT
Created attachment 100947 [details]
airo-422.txt

dmesg with 422 kernel showing airo failure.
Comment 2 Warren Togami 2004-06-07 19:19:20 EDT
Created attachment 100948 [details]
airo-397-working.txt

dmesg from 397 kernel showing working behavior prior to RFMON patch.
Comment 3 Fabrice Bellet 2004-06-08 13:49:10 EDT
Created attachment 100972 [details]
reenable card reset when module is loaded

On my laptop (T40), it appeared that the initial card reset was not needed, but
this was certainly a bad idea, if it breaks on other hardwares ? Does this
patch helps ?

I also removed the card reset in airo_pci_resume() too, invoked when coming
back from APM/ACPI suspend, because I observed that the card could no longer
associate when coming back from Monitor to Managed mode, after the reset
command was issued (in airo_pci_resume()). Moreover, removing this reset didn't
generate bad consequences in my case, but YMMV. 

So, if this patch works, does the card properly resume from ACPI and from APM
suspend too ? (it should not be necessary to ifdown/ifup the interface in the
apm scripts)
Comment 4 Fabrice Bellet 2004-06-10 13:04:49 EDT
I made some tests, and discovered that this buggy behaviour is
triggered by kudzu, and resolved by the above patch. If you don't see
other problems, I'll submit it to Javier.
Comment 5 Fabrice Bellet 2004-06-20 17:44:55 EDT
The bug should be fixed in 2.6.7-bk3.
Comment 6 Warren Togami 2004-06-22 00:24:28 EDT
Thanks.  Our latest released kernel reverted to the old airo, but we
will be sure that your latest airo driver is tested with our rawhide
kernels.
Comment 7 Warren Togami 2004-06-23 02:47:21 EDT
kernel-2.6.7-1.448 seems to work on all firmware versions without
problems.  Great work Fabrice! =)
Comment 8 Mirko Zeibig 2004-08-10 09:19:55 EDT
Hm, I have a Thinkpad R40 with a Mini PCI 350 (Firmware 5b00.08), 
which on Fedora Core 2, which works with kernel-2.6.5-1.358 and does 
not work with kernel-2.6.7-1.494.2.2. The latter will not even allow 
to unload the module again. 
Comment 9 Mirko Zeibig 2004-08-10 09:21:47 EDT
Oh, and I have kudzu disabled during startup. 
 
Regards 
Mirko 
Comment 10 Fabrice Bellet 2004-09-09 16:36:52 EDT
I tested with firmware 5.00.03 and kernel-2.6.7-1.494.2.2, and it
works for me (it associates to the AP, with WEP enabled).
Unfortunately, firmware 5b00.08 isn't available from Cisco web site,
so I cannot use this exact version. Do you have any related errors in
the logs ?

Note You need to log in before you can comment on or make changes to this bug.