Bug 1254890 - Rhevm-reports ignores default location for jboss
Rhevm-reports ignores default location for jboss
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.6.0
All All
medium Severity urgent
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Shirly Radco
Lukas Svaty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 04:01 EDT by Lukas Svaty
Modified: 2016-03-09 16:20 EST (History)
8 users (show)

See Also:
Fixed In Version: 3.6.0-beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 16:20:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Svaty 2015-08-19 04:01:29 EDT
Description of problem:
Setup reports is ignoring path in 

/etc/ovirt-engine-setup.conf.d/20-packaging-rhevm-reports.conf 

set to 

OVESETUP_CONFIG/jbossHome=str:/usr/share/jbossas

and instead using /usr/share/jboss-as, therefore setup fails. 

Version-Release number of selected component (if applicable):
rhevm-reports-setup-3.6.0-0.4.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install engine & dwh on a server
2. On second server try to install rhevm-reports

Actual results:
[ ERROR ] Failed to execute stage 'Misc configuration': Cannot find Jboss at /usr/share/jboss-as


Expected results:
Read jboss path from config file.

Additional info:
setting --jboss-home=dir parameter of engine-setup does not work as rhevm-reports is ignoring this parameter (another/same bug?)


~ engine-setup
...
[ INFO  ] Creating PostgreSQL 'ovirt_engine_reports' database
[ INFO  ] Configuring PostgreSQL
[ ERROR ] Failed to execute stage 'Misc configuration': Cannot find Jboss at /usr/share/jboss-as
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20150819095111-ef6u76.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20150819095617-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed
Comment 3 Lukas Svaty 2015-08-19 04:39:38 EDT
It appears rhevm is reading jboss path from OVESETUP_REPORTS_CONFIG/jbossHome setting this to correct jboss path solved the issue. In the config file this variable should be included and set to default jboss path. The OVESETUP_CONFIG/jbossHome should be probably replaced by this. 

Correct conf line:
OVESETUP_REPORTS_CONFIG/jbossHome=str:/usr/share/jbossas
Comment 4 Lukas Svaty 2015-09-08 07:17:31 EDT
verified in rhevm-reports-3.6.0-0.6.el6ev.noarch
Comment 6 errata-xmlrpc 2016-03-09 16:20:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0425.html

Note You need to log in before you can comment on or make changes to this bug.