Bug 1254893 - weird bold 'r' letter in WebView
weird bold 'r' letter in WebView
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abattis-cantarell-fonts (Show other bugs)
7.2
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Kalev Lember
QE Internationalization Bugs
: i18n, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 04:04 EDT by Vladimir Benes
Modified: 2015-11-19 03:44 EST (History)
12 users (show)

See Also:
Fixed In Version: abattis-cantarell-fonts-0.0.16-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:44:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (188.88 KB, image/png)
2015-08-19 04:06 EDT, Vladimir Benes
no flags Details
test-wk.c (2.04 KB, text/plain)
2015-08-19 04:11 EDT, Milan Crha
no flags Details
Session screenshot (47.92 KB, image/jpeg)
2015-09-10 08:01 EDT, Vadim Rutkovsky
no flags Details

  None (edit)
Description Vladimir Benes 2015-08-19 04:04:54 EDT
Description of problem:
bold 'r' letter is somehow larger than the rest of the font in evolution.

see attachment for details (see email preview header) 

Version-Release number of selected component (if applicable):
evolution-3.12.11-14.el7.x86_64
Comment 1 Vladimir Benes 2015-08-19 04:06:00 EDT
Created attachment 1064656 [details]
screenshot
Comment 2 Milan Crha 2015-08-19 04:11:03 EDT
Created attachment 1064677 [details]
test-wk.c

A simple test application which reproduces the issue out of evolution, with plain WebKitWebView component. I see the same in Fedora 22, though the difference of the 'r' is not that much visible.
Comment 3 Milan Crha 2015-08-19 04:19:26 EDT
The example uses Cantarell font family with 11pt size. Changing the size to 12pt makes the 'r' look like the other letters.
Comment 7 Mark Chappell 2015-09-07 11:04:52 EDT
Not sure if this helps narrow down the cause, but I'm also seeing the same rendering issue in Thunderbird and TweakTool.
Comment 9 Jakub Steiner 2015-09-08 09:36:17 EDT
This is indeen an issue in the Cantarell font. It has been addressed upstream with the following commit -- https://git.gnome.org/browse/cantarell-fonts/commit/?id=8b8b5200752b717c9571a5d3cb1c1371b0201c68
Comment 10 Marek Kašík 2015-09-08 09:47:28 EDT
Thank you very much. I'm reassigning this to the 'abattis-cantarell-fonts' package then.
Comment 12 Satyabrata Maitra 2015-09-08 12:55:31 EDT
Hi Tomas

Provided the qa_ack for this bug. Expecting the bug gets devel, pm and other required acks as well for the go! :)

Regards
Satya
Comment 15 Vadim Rutkovsky 2015-09-10 08:01:53 EDT
Created attachment 1072113 [details]
Session screenshot

This changes session font, not sure if this is expected
Comment 17 Kalev Lember 2015-09-11 07:10:24 EDT
Jakub, can you confirm please if this change is expected? Here's my two screenshots, before and after the 'r' hinting fix:

https://kalev.fedorapeople.org/rhel72-cantarell1.png
https://kalev.fedorapeople.org/rhel72-cantarell2.png
Comment 18 Kalev Lember 2015-09-11 08:49:07 EDT
Looks like it's caused by rebuilding the otf files with RHEL 7.2's fontforge. With newer fontforge 20141230 in Fedora 22 they come out right, but the older fontforge 20120731b in RHEL 7.2 messes them up.
Comment 19 Kalev Lember 2015-09-11 11:23:13 EDT
OK, the regression should be now fixed in abattis-cantarell-fonts-0.0.16-3.el7.
Comment 21 Bill Sanford 2015-09-11 11:51:51 EDT
Verified with RHEL-7.2-20150904.0 & libreoffice-4.3.7.2-5.el7.x86_64
Comment 22 Bill Sanford 2015-09-11 11:56:25 EDT
And evolution-3.12.11-15.el7.x86_64
Comment 24 errata-xmlrpc 2015-11-19 03:44:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2219.html

Note You need to log in before you can comment on or make changes to this bug.