Bug 125491 - Samba packets with TTL 0
Samba packets with TTL 0
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-07 21:26 EDT by NN Poster
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 13:49:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NN Poster 2004-06-07 21:26:42 EDT
Description of problem:
Samba packaged with RHEL 3 emits name service broadcast packets 
(137/udp) with TTL set to 0, which is illegal according to RFC 791.

(The symptom appears to be specific either to the RHEL build or to a 
particular version of Samba because all other Samba instances that I 
have access to use TTL 1.)

Version-Release number of selected component (if applicable):
samba-3.0.2-6.3E

How reproducible:
always

Steps to Reproduce:
1. /etc/init.d/smb start
2. tethereal -i eth0 -w capture udp port 137 and ip src host <my-ip>
3. tethereal -r capture ip.ttl==0
  
Actual results:
lots of packets

Expected results:
no packets

Additional info:
Comment 1 Andrew Bartlett 2007-01-01 20:26:39 EST
I don't see how Samba can even do this.  We just call sendto().  I suspect a
kernel issue with UDP broadcasts.
Comment 2 Prarit Bhargava 2007-09-12 13:49:35 EDT
NOTABUG based on abartlet's comment.

P.

Note You need to log in before you can comment on or make changes to this bug.