Bug 1254934 - Misleading error messages on brick logs while creating directory (mkdir) on fuse mount
Misleading error messages on brick logs while creating directory (mkdir) on f...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: locks (Show other bugs)
3.8.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On: 1254942 1231224 1371404 1373396
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 05:27 EDT by Ashish Pandey
Modified: 2016-09-06 03:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1231224
Environment:
Last Closed: 2016-06-16 08:31:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashish Pandey 2015-08-19 05:27:33 EDT
+++ This bug was initially created as a clone of Bug #1231224 +++

Description of problem:
Error messages are getting logged on brick logs while creating directories on fuse mount for disperse volumes.

Version-Release number of selected component (if applicable):

[root@aspandey gfsa]# gluster --version
glusterfs 3.8dev built on Jun 12 2015 18:03:10
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.


How reproducible:
100%

Steps to Reproduce:
1. Create disperse volume 1 x (4+2)
2. mount as glusterfs on a mount point /mnt
3. create a directory on mount point i.e. /mnt

See the brick logs. Following error messages are present -
 
[2015-06-12 12:35:14.351684] I [MSGID: 115029] [server-handshake.c:588:server_setvolume] 0-gfs-server: accepted client from aspandey-8997-2015/06/12-12:35:14:330840-gfs-client-0-0-0 (version: 3.8dev)
[2015-06-12 12:35:23.789708] E [posix-helpers.c:1087:posix_handle_pair] 0-gfs-posix: /brick/gluster/rep/A1/dir: key:glusterfs.inodelk-dom-count flags: 1 length:15 error:Operation not supported
[2015-06-12 12:35:23.789731] E [posix.c:1386:posix_mkdir] 0-gfs-posix: setting xattrs on /brick/gluster/rep/A1/dir failed (Operation not supported)


Actual results:
Misleading error messages in brick logs.

Expected results:
There should not be any error message for successful fop's for example directory creation (mkdir).

Additional info:

--- Additional comment from Ashish Pandey on 2015-06-12 08:56:04 EDT ---

http://review.gluster.org/11204

--- Additional comment from Anand Avati on 2015-06-16 01:49:09 EDT ---

REVIEW: http://review.gluster.org/11204 ( locks: Filter virtual xattrs in locks for all the fops) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Anand Avati on 2015-06-18 06:36:15 EDT ---

REVIEW: http://review.gluster.org/11204 ( locks: Filter virtual xattrs in locks for all the fops) posted (#3) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Anand Avati on 2015-06-22 02:08:23 EDT ---

REVIEW: http://review.gluster.org/11204 ( locks: Filter virtual xattrs in locks for all the fops) posted (#4) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Anand Avati on 2015-08-19 04:06:12 EDT ---

REVIEW: http://review.gluster.org/11204 ( locks: Filter virtual xattrs in locks for all the fops) posted (#5) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Anand Avati on 2015-08-19 05:23:40 EDT ---

REVIEW: http://review.gluster.org/11204 ( locks: Filter virtual xattrs in locks for all the fops) posted (#6) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 1 Anand Avati 2015-08-19 05:45:15 EDT
REVIEW: http://review.gluster.org/11957 ( locks: Filter virtual xattrs in locks for all the fops) posted (#2) for review on release-3.7 by Ashish Pandey (aspandey@redhat.com)
Comment 2 Mike McCune 2016-03-28 18:22:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 Vijay Bellur 2016-05-24 08:17:41 EDT
REVIEW: http://review.gluster.org/14520 (cluster/ec: Use correct log levels) posted (#1) for review on release-3.8 by Ashish Pandey (aspandey@redhat.com)
Comment 4 Vijay Bellur 2016-05-27 10:53:26 EDT
REVIEW: http://review.gluster.org/14520 (cluster/ec: Use correct log levels) posted (#2) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)
Comment 5 Vijay Bellur 2016-05-30 10:38:03 EDT
COMMIT: http://review.gluster.org/14520 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 6afe7fb246ece2ee2c10d98fdbd4d331ef43a56b
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Wed Jan 20 14:30:08 2016 +0530

    cluster/ec: Use correct log levels
    
    Problem :
    Misleading messages are getting logged in mount logs
    and bricks log.
    "Mismatching xdata" and "Heal failed" are getting logged
    
    Solution :
    Reduce the level of logs from INFO, WARNING and NOTICE
    to DEBUG level wherever applicable OR use fop_log_level
    to get proper log level.
    
    Backport of commit 02b2750ecc35f88c3262015b401dda962381f9da:
    > Change-Id: Ia824c71e75ab683d3cb8949e1966ea09c9ccce72
    > BUG: 1231224
    > Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    > Reviewed-on: http://review.gluster.org/13266
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    
    Change-Id: Ia824c71e75ab683d3cb8949e1966ea09c9ccce72
    BUG: 1254934
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/14520
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 6 Niels de Vos 2016-06-16 08:31:57 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.