Bug 1254970 - [abrt] evolution: g_closure_unref(): evolution killed by SIGABRT
[abrt] evolution: g_closure_unref(): evolution killed by SIGABRT
Status: CLOSED DUPLICATE of bug 1236293
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:91e7d5af3b5cb44b4fece1b4530...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 07:13 EDT by Davide Repetto
Modified: 2015-08-20 09:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-20 09:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (162.88 KB, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: core_backtrace (114.86 KB, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: dso_list (28.29 KB, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: environ (2.60 KB, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: maps (147.56 KB, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: mountinfo (5.57 KB, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: open_fds (9.14 KB, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: proc_pid_status (1.02 KB, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details
File: var_log_messages (28 bytes, text/plain)
2015-08-19 07:13 EDT, Davide Repetto
no flags Details

  None (edit)
Description Davide Repetto 2015-08-19 07:13:22 EDT
Description of problem:
I Was just Browsing mail.

Version-Release number of selected component:
evolution-3.16.5-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        evolution
crash_function: g_closure_unref
executable:     /usr/bin/evolution
global_pid:     2883
kernel:         4.1.4-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #7 g_closure_unref at gclosure.c:591
 #8 handler_unref_R at gsignal.c:637
 #9 handler_match_free1_R at gsignal.c:466
 #10 signal_handlers_foreach_matched_R at gsignal.c:2724
 #11 g_signal_handlers_disconnect_matched at gsignal.c:2864
 #12 soup_auth_manager_request_unqueued at soup-auth-manager.c:706
 #13 g_cclosure_marshal_VOID__OBJECTv at gmarshal.c:2102
 #14 _g_closure_invoke_va at gclosure.c:831
 #17 soup_session_unqueue_item at soup-session.c:1542
 #18 soup_session_process_queue_item at soup-session.c:2065
Comment 1 Davide Repetto 2015-08-19 07:13:30 EDT
Created attachment 1064742 [details]
File: backtrace
Comment 2 Davide Repetto 2015-08-19 07:13:31 EDT
Created attachment 1064743 [details]
File: cgroup
Comment 3 Davide Repetto 2015-08-19 07:13:37 EDT
Created attachment 1064744 [details]
File: core_backtrace
Comment 4 Davide Repetto 2015-08-19 07:13:40 EDT
Created attachment 1064745 [details]
File: dso_list
Comment 5 Davide Repetto 2015-08-19 07:13:41 EDT
Created attachment 1064746 [details]
File: environ
Comment 6 Davide Repetto 2015-08-19 07:13:43 EDT
Created attachment 1064747 [details]
File: limits
Comment 7 Davide Repetto 2015-08-19 07:13:48 EDT
Created attachment 1064748 [details]
File: maps
Comment 8 Davide Repetto 2015-08-19 07:13:49 EDT
Created attachment 1064749 [details]
File: mountinfo
Comment 9 Davide Repetto 2015-08-19 07:13:51 EDT
Created attachment 1064750 [details]
File: namespaces
Comment 10 Davide Repetto 2015-08-19 07:13:53 EDT
Created attachment 1064751 [details]
File: open_fds
Comment 11 Davide Repetto 2015-08-19 07:13:54 EDT
Created attachment 1064752 [details]
File: proc_pid_status
Comment 12 Davide Repetto 2015-08-19 07:13:55 EDT
Created attachment 1064753 [details]
File: var_log_messages
Comment 13 Milan Crha 2015-08-20 09:55:25 EDT
Thanks for a bug report. The backtrace claims invalid free(), within a thread which was downloading remote image. There were more such threads downloading remote images. I think this is related to bug #1236293, thus I mark this as a duplicate of it.

*** This bug has been marked as a duplicate of bug 1236293 ***

Note You need to log in before you can comment on or make changes to this bug.