Bug 1254978 - gdeploy: remove-brick failures
gdeploy: remove-brick failures
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nandaja Varma
Anush Shetty
: ZStream
Depends On:
Blocks: 1251815
  Show dependency treegraph
 
Reported: 2015-08-19 07:23 EDT by Anush Shetty
Modified: 2016-09-17 10:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: gdeploy-1.0-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-05 08:22:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2015-08-19 07:23:55 EDT
Description of problem: With gdeploy-1.1, remove-brick operations fail consistently. 


Version-Release number of selected component (if applicable): 1.1 


How reproducible: Always


Steps to Reproduce:
1. Install gdeploy (http://file.india.redhat.com/surs/gdeploy/gdeploy-1-1.noarch.rpm)
2. Edit the config file to run remove-brick operations
3. Run gdeploy: gdeploy -k -c /opt/gluster.conf

Actual results:

# gdeploy -k -c /opt/gluster.conf
INFO: Volume management(action: remove-brick) triggered

Warning: Using mountpoint itself as the brick in one or more hosts since force is specified, although not recommended.


PLAY [master] ***************************************************************** 

TASK: [Remove bricks from an existing volume] ********************************* 
failed: [rhshdp03.lab.eng.blr.redhat.com] => {"failed": true}
msg: unsupported parameter for module: command

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/gluster-remove-brick.retry

rhshdp03.lab.eng.blr.redhat.com : ok=0    changed=0    unreachable=0    failed=1   

You can view the generated configuration files inside /tmp/playbooks/


Additional info:


[volume]
action=remove-brick
volname=glustervol2
bricks=rhshdp05.lab.eng.blr.redhat.com:/gluster/brick/vol1_add,rhshdp06.lab.eng.blr.redhat.com:/gluster/brick/vol1_add
state=start
force=yes
Comment 2 Nandaja Varma 2015-09-01 01:52:01 EDT
This one is fixed and is available in the latest build.
Comment 3 Anush Shetty 2015-09-08 05:16:36 EDT
Verified with gdeploy-1.0-9.el7rhgs.noarch
Comment 4 Rejy M Cyriac 2015-10-05 08:22:01 EDT
RHGS 3.1 Update 1

Note You need to log in before you can comment on or make changes to this bug.