Bug 1254989 - lasso dependency issue with glib2
lasso dependency issue with glib2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lasso (Show other bugs)
7.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: John Dennis
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 07:49 EDT by Veronika Kabatova
Modified: 2015-11-19 06:58 EST (History)
6 users (show)

See Also:
Fixed In Version: lasso-2.4.1-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:58:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Veronika Kabatova 2015-08-19 07:49:54 EDT
Description of problem:
After updating lasso, httpd fails to start. Probably dependency problem - after manually updating glib2 httpd starts normally.

Version-Release number of selected component (if applicable):
Update from lasso.x86_64 0:2.4.1-5.el7 to lasso.x86_64 0:2.4.1-6.el7,
need to update glib2 (from glib2-2.40.0-4.el7.x86_64) to glib2-2.42.2-4.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install mod_auth_mellon (installs httpd and lasso as dependencies)
2. yum update lasso
3. service httpd restart

Actual results:
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -xn' for details.

Expected results:
lasso updates glib2 as it's dependency and httpd starts normally

Additional info:
# systemctl status httpd.service -l


httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled)
   Active: failed (Result: exit-code) since Wed 2015-08-19 07:43:43 EDT; 40s ago
  Process: 29701 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
  Process: 29699 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 29699 (code=exited, status=1/FAILURE)

Aug 19 07:43:43 ibm-x3250m4-02.rhts.eng.bos.redhat.com httpd[29699]: httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf.modules.d/10-auth_mellon.conf: Cannot load modules/mod_auth_mellon.so into server: /lib64/liblasso.so.3: undefined symbol: g_type_check_instance_is_fundamentally_a
Aug 19 07:43:43 ibm-x3250m4-02.rhts.eng.bos.redhat.com systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Aug 19 07:43:43 ibm-x3250m4-02.rhts.eng.bos.redhat.com kill[29701]: kill: cannot find process ""
Aug 19 07:43:43 ibm-x3250m4-02.rhts.eng.bos.redhat.com systemd[1]: httpd.service: control process exited, code=exited status=1
Aug 19 07:43:43 ibm-x3250m4-02.rhts.eng.bos.redhat.com systemd[1]: Failed to start The Apache HTTP Server.
Aug 19 07:43:43 ibm-x3250m4-02.rhts.eng.bos.redhat.com systemd[1]: Unit httpd.service entered failed state.
Comment 2 John Dennis 2015-08-31 19:43:39 EDT
This looks like a common problem, one only needs to Google g_type_check_instance_is_fundamentally_a and you get a lot of hits about this being an unresolved symbol.

The function was introduced in the glib git commit 6072e365.

$ git tag --contains 6072e365
2.41.1
2.41.2
2.41.3
2.41.4
2.41.5
2.42.0
2.42.1
2.42.2
2.43.0
2.43.1
2.43.2
2.43.3
2.43.4
2.43.90
2.43.91
2.43.92
2.44.0
2.44.1
2.45.1
2.45.2
2.45.3

so it looks like we'll need a dependency on glib 2.41.1 or higher. I'll look into which RHEL rpms would be the most appropriate to add a dependecy on.

Curious the rpm dependency checker didn't pick this up.
Comment 3 John Dennis 2015-08-31 20:36:52 EDT
So it would appear the new symbol is in glib2 2.42 which to the best of my knowledge is in the 7.2 update. From the original bug report it would appear you install a RHEL 7.2 version of lasso into a RHEL 7.1 system, which we don't support (or so I believe), you can't just cherry pick packages from a RHEL update.

Did you install just one component of a 7.2 update into a 7.1 system?
Comment 4 John Dennis 2015-08-31 21:01:15 EDT
The lasso RPM requires 

libglib-2.0.so.0
libgobject-2.0.so.0

which clearly isn't sufficient.

This seems to be more of an issue with glib2 versioning or rpm dependency generation than a problem inherent in lasso.
Comment 5 Jan Pazdziora 2015-09-01 02:37:34 EDT
(In reply to John Dennis from comment #3)
> So it would appear the new symbol is in glib2 2.42 which to the best of my
> knowledge is in the 7.2 update. From the original bug report it would appear
> you install a RHEL 7.2 version of lasso into a RHEL 7.1 system, which we
> don't support (or so I believe), you can't just cherry pick packages from a
> RHEL update.
> 
> Did you install just one component of a 7.2 update into a 7.1 system?

Yes, on RHEL 7.1 installation subscribed to 7.2 content,

   yum update lasso

was invoked. You say that is unsupported?
Comment 14 errata-xmlrpc 2015-11-19 06:58:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2367.html

Note You need to log in before you can comment on or make changes to this bug.