Bug 1255046 - Bad log levels in check_password module
Bad log levels in check_password module
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap (Show other bugs)
6.7
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Matus Honek
Marek Marusic
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 09:36 EDT by Jean-Charles ROGEZ
Modified: 2016-05-17 08:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: openldap-2.4.40-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1356158 (view as bug list)
Environment:
Last Closed: 2016-05-10 20:59:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Charles ROGEZ 2015-08-19 09:36:08 EDT
Description of problem:

RHEL 6.7 introduced a new OpenLDAP module check_password that outputs debug messages as notice messages and notice messages as debug messages.

Version-Release number of selected component (if applicable):
openldap-2.4.40-5.el6.x86_64

Additional info:

These messages should be at debug level :

2015-08-19T15:00:59.628+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Got line |# This file is managed by Puppet. DO NOT EDIT |
2015-08-19T15:00:59.628+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Skipped line |# This file is managed by Puppet. DO NOT EDIT |
2015-08-19T15:00:59.628+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Got line |# OpenLdap checkpassword configuration |
2015-08-19T15:00:59.628+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Skipped line |# OpenLdap checkpassword configuration |
2015-08-19T15:00:59.628+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Got line | |
2015-08-19T15:00:59.628+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Got line |minPoints 2 |
2015-08-19T15:00:59.628+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Validating parameter [minPoints]
2015-08-19T15:00:59.628+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Parameter accepted.
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Word = minPoints, value = 2
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Got line |useCracklib 1 |
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Validating parameter [useCracklib]
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Parameter accepted.
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Word = useCracklib, value = 1
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Got line |minUpper 1 |
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Validating parameter [minUpper]
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Parameter accepted.
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Word = minUpper, value = 1
2015-08-19T15:00:59.629+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Got line |minLower 1 |
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Validating parameter [minLower]
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Parameter accepted.
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Word = minLower, value = 1
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Got line |minDigit 1 |
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Validating parameter [minDigit]
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Parameter accepted.
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Word = minDigit, value = 1
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Got line |minPunct 1 |
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Validating parameter [minPunct]
2015-08-19T15:00:59.631+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Parameter accepted.
2015-08-19T15:00:59.633+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Word = minPunct, value = 1
2015-08-19T15:00:59.633+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Found upper character - quality raise 1
2015-08-19T15:00:59.633+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Found lower character - quality raise 2
2015-08-19T15:00:59.633+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Found digit character - quality raise 3
2015-08-19T15:00:59.633+02:00 ssodb-332.passage.si.c-s.fr local4 notice slapd[30016] check_password: Found punctuation character - quality raise 4

This one should be at notice or warning level :

2015-08-19T12:46:55.873+02:00 debug slapd[6742] check_password_quality: module error: (check_password.so) Password for dn="uid=0000000,dmdName=Personnes,dc=interieur,dc=gouv,dc=fr" does not pass required number of strength checks for the required character sets (3 of 2).[1]
Comment 7 errata-xmlrpc 2016-05-10 20:59:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0943.html

Note You need to log in before you can comment on or make changes to this bug.