Bug 1255066 - inst.sshd option doesn't work i. e. sshd fails to start during installation
inst.sshd option doesn't work i. e. sshd fails to start during installation
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
RejectedBlocker AcceptedFreezeException
:
Depends On: 1255175
Blocks: ZedoraTracker F23BetaFreezeException F23PPCAlpha
  Show dependency treegraph
 
Reported: 2015-08-19 10:13 EDT by Jakub Čajka
Modified: 2015-09-07 12:35 EDT (History)
10 users (show)

See Also:
Fixed In Version: 1.12.2-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-07 12:35:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Čajka 2015-08-19 10:13:16 EDT
Description of problem:
sshd fails to start during installation

How reproducible:
Always with Fedora-Server-DVD-x86_64-23_Alpha.iso
       and  Fedora-Server-DVD-ppc64le-23.iso(Alpha_RC1)

Steps to Reproduce:
1. use inst.sshd and inst.sshpw options
2. check logs to see sshd fail and/or try to ssh in to the installation

Actual results:
sshd fails to start

Expected results:
sshd starts and is accessible

Additional info:

First observed on ppc64le investigating other issue, also reproducible on x86_64 alpha Server DVD.

except from /var/log/anaconda/journal.log after successful installation on ppc64le(similar failure is logged on x86_64)

.
.
.
Aug 19 09:58:28 generic-02.lab.eng.brq.redhat.com  sshd-keygen[10929]: Generating SSH2 RSA host key: [  OK  ]
Aug 19 09:58:28 generic-02.lab.eng.brq.redhat.com  sshd-keygen[10929]: Generating SSH2 ECDSA host key: [  OK  ]
Aug 19 09:58:28 generic-02.lab.eng.brq.redhat.com  sshd-keygen[10929]: Generating SSH2 ED25519 host key: [  OK  ]
.
.
.
Aug 19 09:58:38 generic-02 handle-sshpw[10975]: Traceback (most recent call last):
Aug 19 09:58:38 generic-02 handle-sshpw[10975]: File "/usr/sbin/handle-sshpw", line 30, in <module>
Aug 19 09:58:38 generic-02 handle-sshpw[10975]: import pyanaconda.users as users
Aug 19 09:58:38 generic-02 handle-sshpw[10975]: File "/usr/lib64/python3.4/site-packages/pyanaconda/users.py", line 22, in <module>
Aug 19 09:58:38 generic-02 handle-sshpw[10975]: import libuser
Aug 19 09:58:38 generic-02 handle-sshpw[10975]: NotImplementedError: libuser does not support non-UTF-8 locales with Python 3 (currently using ANSI_X3.4-1968)
Aug 19 09:58:38 generic-02 systemd[1]: anaconda-sshd.service: Control process exited, code=exited status=1
Aug 19 09:58:38 generic-02 systemd[1]: Failed to start OpenSSH server daemon.
Aug 19 09:58:38 generic-02 systemd[1]: anaconda-sshd.service: Unit entered failed state.
.
.
.
Comment 1 Fedora Blocker Bugs Application 2015-08-19 11:25:08 EDT
Proposed as a Freeze Exception for 23-beta by Fedora user pbrobinson using the blocker tracking app because:

 I don't believe (but might well be wrong here) this is a blocker but as it affects anaconda and makes debuging of installs hard I'm requesting a exception to ensure it's suitably tracked
Comment 2 David Shea 2015-08-20 13:36:30 EDT
Posted a patch to fix the libuser behavior by not using libuser anymore, but it needs a fix in useradd in order to work right.
Comment 3 Adam Williamson 2015-08-24 12:37:30 EDT
Discussed at 2015-08-24 freeze exception review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-24/f23-blocker-review.2015-08-24-16.03.log.txt . Accepted as a Beta freeze exception issue: this makes installation debugging somewhat harder and cannot be fixed with an update.
Comment 4 Fedora Blocker Bugs Application 2015-08-26 15:37:35 EDT
Proposed as a Blocker for 23-final by Fedora user sbueno using the blocker tracking app because:

 If sshd does not start, it is not possible to perform an interactive installation on s390x. I know that s390x is not a primary arch, hence the 23-final milestone.
Comment 5 Adam Williamson 2015-08-31 12:42:26 EDT
Discussed at 2015-08-31 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-31/f23-blocker-review.2015-08-31-16.01.log.txt . For primary arches this is an inconvenience not a showstopper, and secondary arch issues cannot be release blocking by policy, so this is rejected as a release blocker. Note that doesn't mean it won't be fixed, just that we won't delay primary arch releases to fix it.
Comment 6 Fedora Update System 2015-09-03 15:33:56 EDT
python-blivet-1.12.2-1.fc23 anaconda-23.19.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15030
Comment 7 Fedora Update System 2015-09-04 03:33:24 EDT
anaconda-23.19.2-1.fc23, python-blivet-1.12.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15030
Comment 8 Fedora Update System 2015-09-07 12:35:33 EDT
anaconda-23.19.2-1.fc23, python-blivet-1.12.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.