Bug 1255086 - Hammer reads local config file named config but should skip it because it isnt a directory
Hammer reads local config file named config but should skip it because it isn...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
http://projects.theforeman.org/issues...
:
: 1346363 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 10:56 EDT by Fred van Zwieten
Modified: 2017-01-12 10:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-12 10:14:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12227 None None None 2016-04-22 12:35 EDT

  None (edit)
Description Fred van Zwieten 2015-08-19 10:56:37 EDT
Description of problem:
Hammer reads a set of config files at start. If in the local directory there is a *file* called "config" it tries to read it as a hammer config file. However, the hammer documentation stated it should only read config files from a local *directory* named config, if it is present.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create local config file with random content
2. hammer shell
3.

Actual results:
error's because it cannot interpret the config file 

Expected results:
normal hammer startup where config is ignored

Additional info:
Comment 1 Bryan Kearney 2015-10-20 13:51:19 EDT
Created redmine issue http://projects.theforeman.org/issues/12227 from this bug
Comment 2 Bryan Kearney 2016-06-16 07:46:04 EDT
*** Bug 1346363 has been marked as a duplicate of this bug. ***
Comment 3 Bryan Kearney 2017-01-12 10:14:17 EST
This is an older bug which has been reported upstream. We are not going to track this bug downstream. When the upstream issue is resolved, the next build will contain the fix. Thank you.

Note You need to log in before you can comment on or make changes to this bug.