Bug 1255089 - Quota error message for invalid size of description is not informative enough
Quota error message for invalid size of description is not informative enough
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: bugs@ovirt.org
meital avital
: Improvement, StringChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 10:59 EDT by Tomer Saban
Modified: 2016-11-23 06:30 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-23 06:30:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dfediuck: ovirt‑4.1?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Tomer Saban 2015-08-19 10:59:40 EDT
Description of problem:
When Creating/Changing Quota the error message for invalid size of description of the quota is not informative enough. It tells that the size is invalid but not telling it's the size of the description.

How reproducible:
100%

Steps to Reproduce:
1. On some Data center enable audit quota.
2. Create a quota with the following string as quota description:
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

(This are 257 'a' characters, while the limit is 250 for description)

Results:
Error message appears "Error while executing action: size must be between 1 and 250"

This error message is caused by too long description(more than 250 characters). it should be changed to something more informative.
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:57:44 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Doron Fediuck 2016-11-23 06:30:42 EST
Closing due to capacity constraints.
If needed patches are welcomed.

Note You need to log in before you can comment on or make changes to this bug.