Bug 1255101 - Network TUI display two NTP servers when you configure only one NTP server on TUI
Network TUI display two NTP servers when you configure only one NTP server on...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.4
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 11:39 EDT by Chaofeng Wu
Modified: 2016-02-10 15:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 09:23:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chaofeng Wu 2015-08-19 11:39:13 EDT
Description of problem:
Configure only one NTP server on TUI, then reboot the system, the TUI will show two NTP server.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.1-20150813.0.iso

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.1-20150813.0.iso, configure the network with dhcp mode, reboot the system.
2. Configure the NTP server with "clock.redhat.com", leave the other NTP server line with blank, then save.
3. Then reboot the system, check the NTP server on network TUI.

Actual results:
After step3, there are two NTP server on network TUI.

Expected results:
After step3, there should be only one NTP server on network TUI.

Additional info:
Drop into shell you can find that:
[root@localhost admin]# cat /etc/ntp.conf 
driftfile /var/lib/ntp/drift
includefile /etc/ntp/crypto/pw
keys /etc/ntp/keys
server clock.redhat.com
server 10.5.26.10   # added by /sbin/dhclient-script
server 10.5.27.10   # added by /sbin/dhclient-script

BTW, if you configure the network with static mode, this issue is gone.
Comment 1 Fabian Deutsch 2015-09-30 09:23:12 EDT
The issues seems to be that dhcp is adding additional NTP servers, so the system is behaving as expected.

Independently of that this functionality will move to a different component, thus I'm closing this bug on this component.

Note You need to log in before you can comment on or make changes to this bug.