Bug 1255103 - ipsilon-client-install man page not installed with ipsilon-client
ipsilon-client-install man page not installed with ipsilon-client
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipsilon (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
Depends On: 1246404
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 11:41 EDT by Veronika Kabatova
Modified: 2015-11-19 05:50 EST (History)
7 users (show)

See Also:
Fixed In Version: ipsilon-1.0.0-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1246404
Environment:
Last Closed: 2015-11-19 05:50:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Veronika Kabatova 2015-08-19 11:41:42 EDT
+++ This bug was initially created as a clone of Bug #1246404 +++

Description of problem:

On ipsilon server, man ipsilon points to ipsilon-server-install(1) and ipsilon-client-install(1) and indeed, both are available (even if there is no ipsilon-client on the server).

However, on the client where one would actually like to read the ipsilon-client-install man page, it is not available.

Version-Release number of selected component (if applicable):

ipsilon-client-1.0.0-1.fc22.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. dnf install -y ipsilon-client
2. type ipsilon-client-install
3. man ipsilon-client-install

Actual results:

# type ipsilon-client-install
ipsilon-client-install is hashed (/usr/bin/ipsilon-client-install)
# man ipsilon-client-install
No manual entry for ipsilon-client-install

Expected results:

If I have ipsilon-client, I should have its man page as well:

# type ipsilon-client-install
ipsilon-client-install is hashed (/usr/bin/ipsilon-client-install)
# man ipsilon-client-install
ipsilon-client-install(1)    Ipsilon Manual Pages    ipsilon-client-install(1)

NAME
       ipsilon-client-install - Configure an Ipsilon client

SYNOPSIS
       ipsilon-client-install [OPTION]...

Additional info:

# rpm -qf /usr/share/man/man1/ipsilon-client-install.1.gz
ipsilon-base-1.0.0-1.fc22.noarch

But that package is not needed/installed on the client.
Comment 1 Veronika Kabatova 2015-08-19 11:43:18 EDT
The same problem is present in RHEL-7.2-20150817.n.2 compose

rpm -q ipsilon-client
ipsilon-client-1.0.0-5.el7.noarch
Comment 6 Scott Poore 2015-09-02 15:17:02 EDT
Verified.

Version ::

ipsilon-client-1.0.0-8.el7.noarch

Results ::


[root@master yum.local.d]# yum install -y ipsilon-client
Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package ipsilon-client.noarch 0:1.0.0-8.el7 will be installed
--> Processing Dependency: ipsilon-saml2-base = 1.0.0-8.el7 for package: ipsilon-client-1.0.0-8.el7.noarch
--> Processing Dependency: ipsilon-filesystem = 1.0.0-8.el7 for package: ipsilon-client-1.0.0-8.el7.noarch
--> Running transaction check
---> Package ipsilon-filesystem.noarch 0:1.0.0-8.el7 will be installed
---> Package ipsilon-saml2-base.noarch 0:1.0.0-8.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================
 Package                  Arch         Version             Repository     Size
===============================================================================
Installing:
 ipsilon-client           noarch       1.0.0-8.el7         mylocal        11 k
Installing for dependencies:
 ipsilon-filesystem       noarch       1.0.0-8.el7         mylocal        22 k
 ipsilon-saml2-base       noarch       1.0.0-8.el7         mylocal        10 k

Transaction Summary
===============================================================================
Install  1 Package (+2 Dependent packages)

Total download size: 43 k
Installed size: 78 k
Downloading packages:
-------------------------------------------------------------------------------
Total                                              18 MB/s |  43 kB  00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : ipsilon-filesystem-1.0.0-8.el7.noarch                       1/3 
  Installing : ipsilon-saml2-base-1.0.0-8.el7.noarch                       2/3 
  Installing : ipsilon-client-1.0.0-8.el7.noarch                           3/3 
  Verifying  : ipsilon-client-1.0.0-8.el7.noarch                           1/3 
  Verifying  : ipsilon-saml2-base-1.0.0-8.el7.noarch                       2/3 
  Verifying  : ipsilon-filesystem-1.0.0-8.el7.noarch                       3/3 

Installed:
  ipsilon-client.noarch 0:1.0.0-8.el7                                          

Dependency Installed:
  ipsilon-filesystem.noarch 0:1.0.0-8.el7                                      
  ipsilon-saml2-base.noarch 0:1.0.0-8.el7                                      

Complete!


[root@master yum.local.d]# man ipsilon-client-install |head
<standard input>:65: warning [p 2, 1.3i]: cannot adjust line
ipsilon-client-install(1)    Ipsilon Manual Pages   ipsilon-client-install(1)



NAME
       ipsilon-client-install - Configure an Ipsilon client

SYNOPSIS
       ipsilon-client-install [OPTION]...

[root@master yum.local.d]# rpm -qa|grep ipsilon
ipsilon-saml2-base-1.0.0-8.el7.noarch
ipsilon-filesystem-1.0.0-8.el7.noarch
ipsilon-client-1.0.0-8.el7.noarch
Comment 7 errata-xmlrpc 2015-11-19 05:50:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2319.html

Note You need to log in before you can comment on or make changes to this bug.