Bug 1255131 - postfix/procmail Insufficient privileges; nonzero status 77; mail not delivered
postfix/procmail Insufficient privileges; nonzero status 77; mail not delivered
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 13:12 EDT by Ronald L Humble
Modified: 2016-01-29 05:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 05:37:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald L Humble 2015-08-19 13:12:44 EDT
Description of problem: net install fc23 KDE Workstation; install/configure postfix; mail fails or delivers with error 77


Version-Release number of selected component (if applicable):
postfix-3.0.2-1.fc23.x86_64
procmail-3.22-38.fc23.x86_64

How reproducible: configured as with fc22 for local mail. Start postfix.
echo "something" | mailx -s "subject" root - FAILS

Steps to Reproduce:
1.
2.
3.

Actual results:
MDA returned nonzero status 77
procmail: Insufficient privileges

Mail to non-root delivered, but error messages above continue
Expected results:
mail delivered to /var/spool/mail/root (or other user)

Additional info:
Initially received error:
"No configuration file found at /home/user/.esmtprc or /etc/esmtprc"

Installed esmtp-local-delivery-1.0-14.fc23.x86_64 (postfix dependency problem?)

Had to install "sendmail" rpm (but not run it) to clear errors. postfix runs as expected with the two additional rpm installs. 

May only be mildly related, but prior to sendmail install, there was no /bin/newaliases program (though listed in rpm -ql postfix). After sendmail rpm install:
/bin/newaliases -> /etc/alternatives/mta-newaliases
/etc/alternatives/mta-newaliases -> /usr/bin/newaliases.sendmail
Comment 1 grobi 2015-12-02 06:03:26 EST
Similar behavior for me on FC22. 

Installing postfix does not lead to a working smtp setup:

yum install postfix cyrus-sasl cyrus-sasl-plain mailx
# configure /etc/postfix/main.cf
systemctl restart postfix
systemctl enable postfix
echo "hallo" | mailx -s "test mail" me@mydomain

... results in "No configuration file found at /root/.esmtprc or /etc/esmtprc" and email not beeing sent out.


I could workaround this behavior by installing sendmail alongside postfix as mentioned above. But that's no proper fix.
Comment 2 Kyle 2016-01-28 23:04:38 EST
I suspect this is an issue with the alternatives configuration - on F23 postfix has the same priority as esmtp in alternatives, so it never switched when I installed it.

I switched to using postfix using alternatives --config mta
Comment 3 Jaroslav Škarvada 2016-01-29 03:59:21 EST
Interesting, it uses the same priority since at least 2007, maybe longer. I think that postfix should have higher priority. I am going to increase it to e.g. 60 (from 30).
Comment 4 Jaroslav Škarvada 2016-01-29 05:10:34 EST
This behaviour was there for very long time, so there is probably no need to fix it in the stable release. That's why I am reassigning it and fixing it in rawhide.

Note You need to log in before you can comment on or make changes to this bug.