Bug 1255142 - Unable to mount inside /dev
Unable to mount inside /dev
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
: 1261207 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 14:11 EDT by David Caro
Modified: 2016-06-26 19:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.2.13-2.fc22 mock-1.2.13-2.fc21 mock-1.2.13-2.el7 mock-1.2.13-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 00:10:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Caro 2015-08-19 14:11:50 EDT
Description of problem:
When specifying a directory to mount that should be created inside the chroot /dev directory, the directory is not mounted there. It actually seems that it's removed mainly because it's mounted before the /dev is setup in the chroot.

Version-Release number of selected component (if applicable):
mock-1.2.12-1.fc22.noarch

How reproducible:
Try to mount a dir inside the /dev dir of the chroot, for example adding the following to the mock config:

config_opts["plugin_conf"]["bind_mount_enable"]='True'
config_opts["plugin_conf"]["bind_mount_opts"]["dirs"]=[
    ['/mydir', u'/dev/mydir'],
]


Steps to Reproduce:
1.Add the mount options to the mock config
2.Try to create the chroot
3.

Actual results:
ERROR: Command failed. See logs for output.
 # /bin/mount -n --bind /mydir /var/lib/mock/fedora-22-x86_64/root/dev/mydir


Expected results:
Chroot created correctly with /mydir mounted at /dev/mydir

Additional info:
Comment 1 Miroslav Suchý 2015-09-04 04:23:27 EDT
While I can reproduce it with mock-1.2.12, I cannot reproduce it with development version of mock.
I guess this was fixed as side effect of commit 16a8c44.
Comment 2 Miroslav Suchý 2015-09-09 02:50:20 EDT
*** Bug 1261207 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2015-09-16 16:01:56 EDT
mock-1.2.13-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16053
Comment 4 Fedora Update System 2015-09-16 16:04:54 EDT
mock-1.2.13-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16054
Comment 5 Fedora Update System 2015-09-16 16:06:53 EDT
mock-1.2.13-2.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16056
Comment 6 Fedora Update System 2015-09-16 16:08:37 EDT
mock-1.2.13-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8114
Comment 7 Fedora Update System 2015-09-16 16:09:43 EDT
mock-1.2.13-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8115
Comment 8 Fedora Update System 2015-09-17 17:30:05 EDT
mock-1.2.13-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16054
Comment 9 Fedora Update System 2015-09-18 01:21:00 EDT
mock-1.2.13-2.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16056
Comment 10 Fedora Update System 2015-09-18 12:24:53 EDT
mock-1.2.13-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16053
Comment 11 Fedora Update System 2015-09-18 23:19:55 EDT
mock-1.2.13-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8115
Comment 12 Fedora Update System 2015-09-18 23:21:45 EDT
mock-1.2.13-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mock'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8114
Comment 13 Fedora Update System 2015-09-23 00:09:06 EDT
mock-1.2.13-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2015-09-24 04:23:15 EDT
mock-1.2.13-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2015-10-05 18:50:34 EDT
mock-1.2.13-2.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2015-10-06 23:05:03 EDT
mock-1.2.13-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-10-07 00:04:50 EDT
mock-1.2.13-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.