This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1255148 - init script fails to start
init script fails to start
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: znc (Show other bugs)
el6
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nick Bebout
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 14:37 EDT by Sarah Day
Modified: 2016-10-07 14:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-07 14:09:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sarah Day 2015-08-19 14:37:03 EDT
Description of problem:

znc init script fails to start giving error:

Starting znc: /usr/bin/dirname: extra operand `2>&1.pid'
Try `/usr/bin/dirname --help' for more information.

Version-Release number of selected component (if applicable):

znc-1.4-1.el6.x86_64

How reproducible:

Always

Steps to Reproduce:
1. start znc: service znc start
2. Watch it fail
3. Release annoyed grunt

Actual results:
Fails to start with error:

Starting znc: /usr/bin/dirname: extra operand `2>&1.pid'
Try `/usr/bin/dirname --help' for more information.

Expected results:

znc starts with no errors
Comment 1 Tomas Smetana 2015-08-20 08:51:02 EDT
The error message is annoying but it's not the reason znc doesn't start... There is no configuration after the installation and znc fails to start because of it.

I made it work by doing the following:

1. Login as root
2. znc -r --makeconf -d /var/lib/znc
   This will ask many questions and create the configuration in /var/lib/znc
   When prompted to "Launch ZNC now?", say no.
3. chown -R znc:znc /var/lib/znc
   ...since we created it as root.
4. service znc start
   This will spit the error message about extra operand again, but znc seems to start just fine.

I understand packaging ZNC is somewhat tough... Maybe fixing the initscript so it would simply refuse to start znc when there is no configuration (and explain why) would make the user's life easier.
Comment 2 Nick Bebout 2016-10-07 14:09:53 EDT
I am retiring ZNC in epel5 and epel6 since there are deps that are not available.

Note You need to log in before you can comment on or make changes to this bug.