Bug 1255150 - Changed files do not show up in egit commit dialog
Changed files do not show up in egit commit dialog
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 14:57 EDT by Timo Klerx
Modified: 2015-09-06 00:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.0.1-8.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-06 00:50:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot eclipse 4.5 commit dialog (198.34 KB, image/png)
2015-08-19 14:57 EDT, Timo Klerx
no flags Details

  None (edit)
Description Timo Klerx 2015-08-19 14:57:21 EDT
Created attachment 1064976 [details]
Screenshot eclipse 4.5 commit dialog

Description of problem:


Version-Release number of selected component (if applicable):
eclipse 4.5.0-5
eclipse-egit-4.0.1-1

How reproducible:
always

Steps to Reproduce:
1. checkout a java eclipse project with egit
2. change some files
3. select team->commit
4. commit dialog opens

Actual results:
only symbols are shown, but no file names/paths

Expected results:
symbols, file names and paths are shown

Additional info:
I know eclipse 4.5 is in the fedora testing repos but it is the stable version announced on eclipse.org and the bug has to be fixed anyway.

bug is similar to https://bugzilla.redhat.com/show_bug.cgi?id=1223946
Comment 1 Roland Grunberg 2015-08-19 16:15:08 EDT
This would seem to be https://bugs.eclipse.org/bugs/show_bug.cgi?id=466499 from upstream. The fix will be released in 4.5.1, though I guess we should consider backporting it here.
Comment 2 Mat Booth 2015-08-20 12:44:46 EDT
(In reply to Roland Grunberg from comment #1)
> This would seem to be https://bugs.eclipse.org/bugs/show_bug.cgi?id=466499
> from upstream. The fix will be released in 4.5.1, though I guess we should
> consider backporting it here.

Oh nice, that patch works for me.
Comment 3 Mat Booth 2015-08-21 06:34:19 EDT
I will issue an update soon.
Comment 4 Fedora Update System 2015-08-26 19:36:26 EDT
eclipse-4.5.0-7.fc22 eclipse-ecf-3.10.1-1.fc22 eclipse-license-1.0.1-8.fc22 eclipse-filesystem-1.0-5.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14368
Comment 5 Fedora Update System 2015-08-28 14:57:56 EDT
eclipse-4.5.0-7.fc22, eclipse-ecf-3.10.1-1.fc22, eclipse-filesystem-1.0-5.fc22, eclipse-license-1.0.1-8.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update eclipse-filesystem eclipse-ecf eclipse eclipse-license'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14368
Comment 6 Fedora Update System 2015-09-06 00:50:04 EDT
eclipse-4.5.0-7.fc22, eclipse-ecf-3.10.1-1.fc22, eclipse-filesystem-1.0-5.fc22, eclipse-license-1.0.1-8.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.