This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1255159 - supervisord fails to start due to inability to create its socket
supervisord fails to start due to inability to create its socket
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: supervisor (Show other bugs)
epel7
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Steve Traylen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 15:40 EDT by George Notaras
Modified: 2015-08-23 22:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.1.3-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-23 22:52:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Notaras 2015-08-19 15:40:57 EDT
Description of problem:

supervisord fails to start with the message:

supervisord: Error: Cannot open an HTTP server: socket.error reported errno.ENOENT (2)

Version-Release number of selected component (if applicable):

supervisor-3.1.3-2.el7.noarch

Additional info:

It appears that after a recent update, the socket path has been changed from:

  /var/tmp/supervisor.sock

to:

  /var/run/supervisor/supervisor.sock

Resolution:

This seems to be happening because the `/var/run/supervisor` directory does not exist. If the aforementioned directory is created before running supervisord, the service starts normally.

Please include a tmpfiles configuration so that the needed directory is auto-created.
Comment 1 Kevin Fenzi 2015-08-19 16:21:47 EDT
Bah. I thought I had. ;( 

will try and correct this soon...
Comment 2 Kevin Fenzi 2015-08-19 17:07:43 EDT
Can you test this scratch build and see if it works in your testing: 

https://koji.fedoraproject.org/koji/taskinfo?taskID=10758575

Thanks.
Comment 3 George Notaras 2015-08-19 17:34:34 EDT
Hi Kevin,

Thanks for looking into this. I've updated to supervisor-3.1.3-3.el7.noarch and it seems to fix the issue. supervisord starts without problems and also supervisorctl works as expected (as root).
Comment 4 Bill Nottingham 2015-08-20 16:16:08 EDT
Yes, that fixes the issue we're seeing here as well.
Comment 5 Fedora Update System 2015-08-20 16:27:37 EDT
supervisor-3.1.3-3.el7 has been submitted as an update to Fedora EPEL 7. https://bugzilla.redhat.com/show_bug.cgi?id=1255159
Comment 6 Fedora Update System 2015-08-22 15:48:54 EDT
supervisor-3.1.3-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update supervisor'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7728
Comment 7 Fedora Update System 2015-08-23 22:52:41 EDT
supervisor-3.1.3-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.