This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1255166 - manpage systemd --test flag is not clearly explained
manpage systemd --test flag is not clearly explained
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.3
All Linux
unspecified Severity low
: rc
: ---
Assigned To: systemd-maint
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 16:18 EDT by Bryan Totty
Modified: 2016-01-12 08:59 EST (History)
3 users (show)

See Also:
Fixed In Version: systemd-219-19.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-12 07:47:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Totty 2015-08-19 16:18:30 EDT
Description of problem:
Please expand the systemd manpage in relation to the `--test` flag. We need to explicitly say that it can only be run in maintenance mode and/or that it's not something you typically run. Right now it can be interpreted as you'll get a list of the startup sequence, which is really not possible since systemd uses socket activation and you can't get everything (socket activation is dynamic and not deterministic). 


Version-Release number of selected component (if applicable):
systemd-208-20.el7_1.5

How reproducible:
Always 

Steps to Reproduce:
1. man systemd
2. search for "--test"

Actual results:
The "--test" option is unclear.

Expected results:
We need to explicitly say that it can only be run in maintenance mode and/or that it's not something you typically run.
Comment 1 Lukáš Nykrýn 2016-01-12 07:47:20 EST
I think that from the current description it is clear:

Determine startup sequence, dump it and exit. This is an option useful for debugging only.
Comment 2 Matt Ruzicka 2016-01-12 08:59:34 EST
Thanks, Lukáš. I think part of the issue was the --test functionality was broken in RHEL 7.1.  Since this is working as expected in RHEL 7.2 I can understand this being closed.

Note You need to log in before you can comment on or make changes to this bug.