Bug 1255169 - gdbus: backport upstream patch to avoid g_warning() during g_dbus_method_invocation_return_value()
gdbus: backport upstream patch to avoid g_warning() during g_dbus_method_invo...
Status: CLOSED DUPLICATE of bug 1266470
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glib2 (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Colin Walters
Desktop QE
:
Depends On:
Blocks: 1253318
  Show dependency treegraph
 
Reported: 2015-08-19 16:24 EDT by Thomas Haller
Modified: 2017-05-11 09:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-11 09:57:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Haller 2015-08-19 16:24:36 EDT
Please backport the upstream commit 

  "gdbus: don't warn when returning a value on a closed connection"

https://git.gnome.org/browse/glib/commit/?id=c6862451411ae3039029fdd1e3697343fa2aed19

(from https://bugzilla.gnome.org/show_bug.cgi?id=753839)


We hit this warning while testing NetworkManager. As we test with G_DEBUG=fatal-warnings, this is bad for testing (bug 1253318)
Comment 2 Thomas Haller 2017-05-11 09:49:15 EDT
btw, due to the rebase to 2.50.3, this automatically is fixed in rhel-7.4.
Comment 3 Colin Walters 2017-05-11 09:57:13 EDT

*** This bug has been marked as a duplicate of bug 1266470 ***

Note You need to log in before you can comment on or make changes to this bug.