Bug 1255182 - Capsule descriptions are trunctated to 32 chars irrespective of cell width
Summary: Capsule descriptions are trunctated to 32 chars irrespective of cell width
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-19 21:06 UTC by Andrew Schofield
Modified: 2019-09-26 14:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1293486 (view as bug list)
Environment:
Last Closed: 2016-07-27 08:54:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13385 None None None 2016-04-22 15:46:56 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Andrew Schofield 2015-08-19 21:06:16 UTC
Description of problem:
Capsule descriptions in the web UI do not resize to the width of the cell (So if your description for the capusule goes over 32 chars then this is only visible on the rollover).


Version-Release number of selected component (if applicable):
6.1.1 GA

How reproducible:
N/A - web layout

Steps to Reproduce:

This is generated by /usr/share/foreman/app/views/smart_proxies/index.html.erb at line 17:

<td><%= link_to_if_authorized trunc(proxy.name), hash_for_edit_smart_proxy_path(:id => proxy).merge(:auth_object => proxy, :authorizer => authorizer) %></td>

And the trunc method (from : /usr/share/foreman/app/helpers/layout_helper.rb) says this:

def trunc(text, length = 32)
    text    = text.to_s
    options = text.size > length ? { :'data-original-title' => text, :rel => 'twipsy' } : {}
    content_tag(:span, truncate(text, :length => length), options).html_safe
  end



Actual results:
Description text is trucated to 32 chars

Expected results:
Text should match the column width

Additional info:

Comment 2 Bryan Kearney 2016-01-12 20:39:09 UTC
Since i missed this earlier... 1255182  is about the capsule name, 1293486 is about the puppet class.

Comment 3 Brad Buckingham 2016-01-26 17:42:35 UTC
Created redmine issue http://projects.theforeman.org/issues/13385 from this bug

Comment 4 Bryan Kearney 2016-01-26 19:00:51 UTC
Upstream bug component is Provisioning

Comment 5 Brad Buckingham 2016-01-27 12:32:07 UTC
Based on the comment in the upstream redmine, this has already been addressed.  Moving the bug to POST, since it should be included with the next rebase.

Comment 8 Lukas Pramuk 2016-04-05 11:25:56 UTC
VERIFIED.

@Sat6.2.0-Beta-Snap6

Smart proxy (=capsule) name at UI is no longer ellipsized at all.
The name is now only wrapped at dashes.

Comment 10 errata-xmlrpc 2016-07-27 08:54:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.