Bug 1255183 - lastcomm missing '--pid' flag that was present in RHEL6
lastcomm missing '--pid' flag that was present in RHEL6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: psacct (Show other bugs)
7.2
All All
unspecified Severity medium
: rc
: ---
Assigned To: Jan Rybar
David Jež
Lenka Kimlickova
:
Depends On:
Blocks: 1298243 1380361 1393867
  Show dependency treegraph
 
Reported: 2015-08-19 17:08 EDT by Frank Hirtz
Modified: 2017-08-01 16:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: psacct-6.6.1-12.el7
Doc Type: Release Note
Doc Text:
"lastcomm" now supports the "--pid" option The "lastcomm" command now supports the "--pid" option. This option shows the process ID (PID) and parent-process ID (PPID) for each record if supported by the kernel.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:35:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lastcomm shows PID and PPID if supported (3.04 KB, patch)
2017-02-13 05:57 EST, Jan Rybar
no flags Details | Diff

  None (edit)
Description Frank Hirtz 2015-08-19 17:08:08 EDT
Description of problem:

In rhel6, the lastcomm binary (part of the psacct package) included a patch which added a flag, --pid, which would print out the processes pid and ppid. 

It looks like that patch (psacct-6.3.2-ppid.patch) was dropped in rhel7. 

We've found it to be very useful and would like to see it restored in rhel7.

Version-Release number of selected component (if applicable):
psacct-6.6.1-9.el7.x86_64

Steps to Reproduce:
1. lastcomm --pid


Actual results:
<snip>
[root@garabaldi ~]# lastcomm --pid
lastcomm: unrecognized option '--pid'
Usage: lastcomm [-hpV] [-f file] [command] ... [user] ... [terminal] ...
       [--forwards] [--file <file>] [--strict-match] [--print-controls]
       [--user <name>] [--tty <name>] [--command <name>] [--debug]
       [--show-paging] [--ahz <freq>] [--version] [--help]

The system's default process accounting file is /var/account/pacct.
[root@garabaldi ~]# 
</snip>

Expected results:
<snip>
[root@ivanova fmhirtz]# lastcomm --pid | head -5
lastcomm                root     pts/0      0.38 secs Wed Aug 19 17:06     3573     3551
postmaster         F    postgres __         0.00 secs Wed Aug 19 17:06     3571     2487
xauth             S     root     pts/0      0.00 secs Wed Aug 19 17:06     3570     3551
bash               F    root     pts/0      0.00 secs Wed Aug 19 17:06     3568     3551
id                      root     pts/0      0.00 secs Wed Aug 19 17:06     3569     3568
<snip>

Additional info:
Comment 1 Jaromír Cápík 2015-08-20 13:35:50 EDT
Hello Frank.

The --pid switch was introduced by the previous component maintainer. Unfortunately the patch didn't get upstream for some reason. I could try to forward-port this and propagate upstream.

Let's see how that goes.

Thanks,
Jaromir.
Comment 7 Jaromír Cápík 2016-01-14 08:52:56 EST
Hello Frank.

The project has a bug tracker on savannah.

https://savannah.gnu.org/bugs/?group=acct

You could also try to contact Markus Gothe <nietzsche@lysator.liu.se> directly.
Comment 13 Jan Rybar 2017-02-13 05:57 EST
Created attachment 1249792 [details]
lastcomm shows PID and PPID if supported
Comment 22 errata-xmlrpc 2017-08-01 16:35:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1953

Note You need to log in before you can comment on or make changes to this bug.