Bug 1255206 - Consider adding installed-files.txt during build
Consider adding installed-files.txt during build
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-cffi (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Picka
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 21:20 EDT by Ian Wienand
Modified: 2016-11-04 00:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-cffi-1.6.0-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:45:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
change to spec to add installed-files.txt (480 bytes, patch)
2015-08-19 21:20 EDT, Ian Wienand
no flags Details | Diff
example of uninstalling cffi with the installed-files.txt file present (3.96 KB, text/plain)
2015-08-19 21:21 EDT, Ian Wienand
no flags Details
evidence (2.96 KB, text/plain)
2016-09-19 07:41 EDT, Pavel Picka
no flags Details

  None (edit)
Description Ian Wienand 2015-08-19 21:20:27 EDT
Created attachment 1065060 [details]
change to spec to add installed-files.txt

First up, I understand mixing pip & packages is not great; but it's a reality of upstream openstack testing & I do think there is room for packages to help out.

I noticed that when doing "pip uninstall cffi" (i.e., what happens before "pip install cffi" to get a later version) the cffi .so is left behind.  This is because pip has no idea it exists; it is just removing the cffi/* and egg directories.

Due to *another* bug in pip [1] we ended up with two cffi .so's on the system with bad results.  After the fix for [1], pip should overwrite the old file ... but it still seems like it would be better if "pip remove" got rid of it.

It seems that with just adding a --record tag to the install, we could ship an installed-files.txt which would help pip to remove everything correctly.

Interested to know what you think...

[1] https://github.com/pypa/pip/pull/3037
Comment 1 Ian Wienand 2015-08-19 21:21:51 EDT
Created attachment 1065061 [details]
example of uninstalling cffi with the installed-files.txt file present
Comment 5 Pavel Picka 2016-09-19 07:41 EDT
Created attachment 1202454 [details]
evidence

Verified 

1.6.0-5
Comment 7 errata-xmlrpc 2016-11-04 00:45:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2371.html

Note You need to log in before you can comment on or make changes to this bug.