This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1255210 - systemd in older Fedora releases needs .service suffix
systemd in older Fedora releases needs .service suffix
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: general (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 21.1
: ---
Assigned To: Dan Callaghan
tools-bugs
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 21:48 EDT by Dan Callaghan
Modified: 2015-10-20 23:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 23:25:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2015-08-19 21:48:07 EDT
Description of problem:
Recent versions of systemd will assume a suffix of .service when you specify a unit name with no suffix, for example:

systemctl enable beah-srv

is equivalent to

systemctl enable beah-srv.service

However older versions did not have this heuristic.

Bug 1202075 has made it possible to provision EOL'ed Fedora releases, and in testing that we discovered this next problem affecting Fedora 17-19.

Version-Release number of selected component (if applicable):
20.2

How reproducible:
easily, with the patch for bug 1202075

Steps to Reproduce:
1. Provision Fedora 19 with ks_meta="no_updates_repos"

Actual results:
Tasks never start because in kickstart %post, beah services fail to be enabled:
+ systemctl enable beah-srv
Operation failed: Invalid argument
...

Expected results:
Kickstart %post succeeds, beah services are enabled and recipe runs successfully.

Additional info:
This is essentially an RFE in the sense that we have never tried to support EOL'ed Fedora releases before.
Comment 1 Dan Callaghan 2015-08-19 23:06:19 EDT
http://gerrit.beaker-project.org/4360

I'm not sure if it's a good idea to cram this into 21.0, given that it affects every single generated kickstart. I am more inclined to leave this for 21.1 (or even 22.0?) and call bug 1202075 done based on the fact that it got past the first error, even though F17-19 are still not able to be provisioned due to this bug.
Comment 4 Dan Callaghan 2015-10-20 23:25:34 EDT
Beaker 21.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.