Bug 1255225 - Spanish strings missing translation for Blivet
Summary: Spanish strings missing translation for Blivet
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-20 03:37 UTC by Abdel Gadiel Martínez Lassonde
Modified: 2015-09-03 17:22 UTC (History)
8 users (show)

Fixed In Version: python-blivet-1.11-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-03 17:22:57 UTC
Type: Bug


Attachments (Terms of Use)
Anaconda es_PA missing strings [1] (411.25 KB, image/png)
2015-08-20 03:38 UTC, Abdel Gadiel Martínez Lassonde
no flags Details
Anaconda es_PA missing strings [2] (541.30 KB, image/png)
2015-08-20 03:39 UTC, Abdel Gadiel Martínez Lassonde
no flags Details

Description Abdel Gadiel Martínez Lassonde 2015-08-20 03:37:21 UTC
Description of problem:
The following strings are missing for Spanish translation: "Destroy Format", "Create Format", "Create Device", "Creating luks on"

Version-Release number of selected component (if applicable):
23 Alpha

How reproducible:
Change locale to es_PA and start liveinst (Anaconda)

Steps to Reproduce:
1. Edit: vi /etc/locale.conf
2. Load: source /etc/locale.conf
3. Execute: liveinst

Actual results:
Strings in English

Expected results:
Strings in Spanish

Additional info:
Looked for the strings in Zanata but there are no available.

Comment 1 Abdel Gadiel Martínez Lassonde 2015-08-20 03:38:48 UTC
Created attachment 1065070 [details]
Anaconda es_PA missing strings [1]

Here are the strings "Destroy Format", "Create Format", "Create Device".

Comment 2 Abdel Gadiel Martínez Lassonde 2015-08-20 03:39:32 UTC
Created attachment 1065071 [details]
Anaconda es_PA missing strings [2]

Here is the string: "Creating luks on"

Comment 3 Máximo Castañeda 2015-08-31 09:52:16 UTC
Those strings don't appear in Anaconda's source.  They seem to belong to Blivet, that is used by Anaconda to manage storage.  The strings are in Blivet's source, and in Zanata for Blivet, both in f23-branch and in master, since January.

Comment 4 David Shea 2015-09-03 17:22:57 UTC
There was an issue with packaging the translations in blivet that unfortunately did not make it into alpha. If you run 'sudo dnf upgrade python3-blivet' before the install, the strings will be translated.

However:
> 1. Edit: vi /etc/locale.conf
> 2. Load: source /etc/locale.conf

This is not how you change the locale. /etc/locale.conf is used by systemd at boot time to configure some system-wide settings, and modifying the file will not change the locale settings in the current environment. Although the file looks like a shell script, it is not intended to be used as one, and sourcing the file will not change your current settings, since the new environment variables will not be exported to child processes.

You can change the language used in the live environment through the Region and Language settings, and you can change the language used by the installer at the first screen that asks you to select your language.


Note You need to log in before you can comment on or make changes to this bug.