Bug 1255251 - DDL importer does not properly set Materialized table options
DDL importer does not properly set Materialized table options
Status: CLOSED DEFERRED
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Barry LaFond
Andrej Smigala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 02:42 EDT by Andrej Smigala
Modified: 2016-09-13 08:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If the user attempts to import a DDL, the Materialized property of the view table is set, but the Materialized Table property is not. To workaround this issue, the user must manually set the Materialized Table property after import.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-05 03:49:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2622 Major Closed DDL importer does not properly set Materialized table options 2016-09-13 08:28 EDT

  None (edit)
Description Andrej Smigala 2015-08-20 02:42:08 EDT
Importing a DDL similar to the one in [1], the Materialized property of the view table is set, but the Materialized Table property is not.

[1] https://docs.jboss.org/author/display/teiid810final/External+Materialization?_sscc=t
Comment 2 Barry LaFond 2015-08-24 08:58:02 EDT
Targeting 9.0.4 Designer, 8.0.4 JBDSIS
Comment 3 Barry LaFond 2015-08-24 09:06:14 EDT
This should be a known issue and the work-around is to set the materialized table manually after import.
Comment 4 Barry LaFond 2015-09-10 16:29:53 EDT
Pushing JIRA to DV 6.3 Tooling
Comment 5 JBoss JIRA Server 2015-12-11 09:31:51 EST
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2622 to Resolved
Comment 6 Matus Makovy 2016-02-05 03:49:42 EST
Closing this since we are tracking issues for tooling only in JIRA from now on.
Comment 7 JBoss JIRA Server 2016-03-02 08:51:39 EST
Matus Makovy <mmakovy@redhat.com> updated the status of jira TEIIDDES-2622 to Reopened
Comment 8 JBoss JIRA Server 2016-03-02 15:27:02 EST
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2622 to Resolved
Comment 9 JBoss JIRA Server 2016-07-22 06:32:29 EDT
Matus Makovy <mmakovy@redhat.com> updated the status of jira TEIIDDES-2622 to Reopened
Comment 10 JBoss JIRA Server 2016-08-25 15:43:39 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-2622 to Resolved
Comment 11 JBoss JIRA Server 2016-09-13 08:28:48 EDT
Matus Makovy <mmakovy@redhat.com> updated the status of jira TEIIDDES-2622 to Closed

Note You need to log in before you can comment on or make changes to this bug.