Bug 1255274 - fedpkg update not working with Bodhi 2
fedpkg update not working with Bodhi 2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Randy Barlow
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 03:39 EDT by Adam Williamson
Modified: 2016-10-17 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-17 19:45:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2015-08-20 03:39:50 EDT
Just tried to submit an update with fedpkg. It exploded:

[adamw@adam owncloud (el6 %)]$ fedpkg update/usr/lib/python2.7/site-packages/fedpkg/cli.py:169: DeprecationWarning: Commands._hash_file is deprecated and will be removed eventually.
    Please use Commands.lookasidecache.hash_file instead.
  hash = self.cmd._hash_file('bodhi.template', 'sha1')
Traceback (most recent call last):
  File "/usr/bin/bodhi", line 537, in <module>
    main()
  File "/usr/bin/bodhi", line 209, in main
    updates = bodhi.parse_file(input_file=opts.input_file)
  File "/usr/lib/python2.7/site-packages/fedora/client/bodhi.py", line 278, in parse_file
    read = config.read(input_file)
  File "/usr/lib64/python2.7/ConfigParser.py", line 305, in read
    self._read(fp, filename)
  File "/usr/lib64/python2.7/ConfigParser.py", line 546, in _read
    raise e
ConfigParser.ParsingError: File contains parsing errors: bodhi.template
	[line 15]: 'caused ownCloud to fail to work at all, unless you had somehow\n'
	[line 16]: 'installed a newer version of PHP. Thanks Guido Berhoerster for alerting\n'
	[line 17]: 'me to this issue.\n'
Could not generate update request: Command 'bodhi --new --release el6 --file bodhi.template owncloud-7.0.7-2.el6 --username adamwill' returned non-zero exit status 1

I have the latest bits, so far as I know:

[adamw@adam owncloud (el6 %)]$ rpm -qf `which fedpkg`
fedpkg-1.20-2.fc23.noarch
[adamw@adam owncloud (el6 %)]$ rpm -q bodhi-client
bodhi-client-0.9.12.2-3.fc23.noarch
[adamw@adam owncloud (el6 %)]$ rpm -q python-fedora
python-fedora-0.5.5-1.fc23.noarch
Comment 1 Adam Williamson 2015-08-20 14:20:33 EDT
this might be because i wrapped the description?
Comment 2 Luke Macken 2015-08-20 14:27:14 EDT
yeah, I'm pretty sure that would error out with bodhi1 as well.
Comment 3 Eugene A. Pivnev 2015-09-04 03:11:00 EDT
(In reply to Luke Macken from comment #2)
> yeah, I'm pretty sure that would error out with bodhi1 as well.

I have same problem (description=Version bump):

bash-4.3$ fedpkg update
/usr/lib/python2.7/site-packages/fedpkg/cli.py:169: DeprecationWarning: Commands._hash_file is deprecated and will be removed eventually.
    Please use Commands.lookasidecache.hash_file instead.
  hash = self.cmd._hash_file('bodhi.template', 'sha1')
Creating a new update for  nomacs-2.4.6-1.fc23 
ServerError(https://admin.fedoraproject.org/updates/save, 404, Not Found)
Traceback (most recent call last):
  File "/bin/bodhi", line 225, in main
    data = bodhi.save(**update_args)
  File "/usr/lib/python2.7/site-packages/fedora/client/bodhi.py", line 111, in save
    'bugs': bugs,
  File "/usr/lib/python2.7/site-packages/fedora/client/baseclient.py", line 369, in send_request
    auth_params=auth_params, retries=retries, timeout=timeout)
  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 488, in send_request
    raise ServerError(url, http_status, msg)
ServerError: ServerError(https://admin.fedoraproject.org/updates/save, 404, Not Found)
Could not generate update request: Command 'bodhi --new --release f23 --file bodhi.template nomacs-2.4.6-1.fc23 --username tieugene' returned non-zero exit status 255

fedpkg-1.20-1.fc21.noarch
bodhi-client-0.9.12.2-1.fc21.noarch
python-fedora-0.3.37-1.fc21.noarch
Comment 4 Jan Kurik 2016-02-24 10:30:54 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Randy Barlow 2016-10-17 17:24:59 EDT
Hello!

I have recently become the primary caretaker of Bodhi and I've inherited a number of issues related to bodhi 0.9. I wanted to be forthcoming with you that it will be difficult for me to fix issues with bodhi 0.9 while also pressing forward with bodhi 2, especially since I do not have any familiarity with the bodhi 0.9 codebase. I'm happy to keep this bug open to track the problem, but I would also encourage you to please test the bodhi 2 client (currently available in Rawhide and Copr[0]). Unfortunately, the bodhi 2 client is not backwards compatible with bodhi 0.9, so at this time I only plan for bodhi 2 to be released with Fedora 26 and EPEL 7 (with special permission from the EPEL SC).

Here are some options you could pursue for this issue:

0) Write a patch for me that can be applied with the spec file. If you are willing to take the time to learn the bodhi 0.9 code, write a patch, and test it, I am willing to accept patches to be applied during build.
1) Use Rawhide.
2) Install bodhi 2 from my Copr[0].

I apologize as I understand that this is probably disappointing news for you to hear, but I thought it would be better to be forthcoming than to let the bug languish. I appreciate your understanding!


[0] https://copr.fedorainfracloud.org/coprs/bowlofeggs/bodhi/
Comment 6 Adam Williamson 2016-10-17 19:45:35 EDT
We can probably just close this one, since it was caused by me sticking newlines in the update description. Arguably that could be tolerated, but meh.

Note You need to log in before you can comment on or make changes to this bug.