Bug 1255278 - [RFE] Make repoquery use "system" metadata
[RFE] Make repoquery use "system" metadata
Status: CLOSED DUPLICATE of bug 1185741
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 04:00 EDT by Vít Ondruch
Modified: 2015-08-31 08:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 08:41:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2015-08-20 04:00:45 EDT
Description of problem:
The DNF is typically operating with root privileges. However, there is no reason for repoquery to have root privileges. Unfortunately, without root privileges, the repoquery goes to fetch all the metadata and hence waste time and resources. So please, could you make repoquery to use the system data without root privileges?


Version-Release number of selected component (if applicable):
$ rpm -q dnf
dnf-1.1.0-2.fc22.noarch


How reproducible:


Steps to Reproduce:
1. sudo dnf repoquery
2. dnf repoquery
3.

Actual results:
Without root privileges, the metadata are fetched, although there is somewhere already (probably) fresh copy


Expected results:
System metadata are used when available, otherwise some warning is issued instead of downloading the metadata (or the metadata is downloaded if DNF is configured in this way)

Additional info:
Comment 1 Radek Holy 2015-08-20 06:31:29 EDT
FTR, I think this issue will disappear once we resolve the bug 1190548.
Comment 2 Honza Silhan 2015-08-31 08:41:48 EDT

*** This bug has been marked as a duplicate of bug 1190548 ***
Comment 3 Honza Silhan 2015-08-31 08:42:45 EDT

*** This bug has been marked as a duplicate of bug 1185741 ***

Note You need to log in before you can comment on or make changes to this bug.