Bug 1255280 - Cannot find iSCSI storage when RHEL 7.2 in device with both local and iSCSI storage
Summary: Cannot find iSCSI storage when RHEL 7.2 in device with both local and iSCSI s...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Vojtech Trefny
QA Contact: Release Test Team
Clayton Spicer
URL:
Whiteboard:
Keywords:
: 1317654 1327138 (view as bug list)
Depends On:
Blocks: 1313485 1213541 1295926 ovirt-node-ng-platform
TreeView+ depends on / blocked
 
Reported: 2015-08-20 08:06 UTC by fwu
Modified: 2016-11-03 23:09 UTC (History)
11 users (show)

Fixed In Version: anaconda-21.48.22.65-1
Doc Type: Release Note
Doc Text:
*Anaconda* no longer crashes when adding iSCSI devices Previously, the *Anaconda* installer terminated unexpectedly when attempting to add certain iSCSI devices using the `Add a disk` button in the `Storage` screen. This bug has now been fixed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:09:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error log screenshot during installation process (17.29 MB, application/zip)
2015-08-20 08:06 UTC, fwu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2158 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2016-11-03 13:13:55 UTC

Description fwu 2015-08-20 08:06:43 UTC
Created attachment 1065135 [details]
Error log screenshot during installation process

Description of problem:
Can not find iscsi storage when RHEL7.2 in device with both local and iSCSI storage

Version-Release number of selected component (if applicable):
kernel-3.10.0-302.el7.x86_64
RHEL-7.2-20150806.1

How reproducible:
100%

Steps to Reproduce:
1. Prepare a machine with a local SATA disk and an iSCSI disk
2. Boot up the system with a RHEL7.2 DVD, check the media to ensure the DVD contains complete data for installation.
3. Enter the graphical interface of installation automatically, set the language as English (United States), then click "Continue".
4. Select "INSTALLATION DESTINATION", the local SATA disk appears under the "Local Standard Disk" label.
5. Click "Add a disk...".

Actual results:
A unknown error has occured and the installation process cannot proceed:
"AttributeError: 'NoneType' object has no attribute 'port'"

Expected results:
During the installation process, a disk can be successfully added as an installation destination.

Additional info:
1. I have tried to use the same DVD to install on a machine with only local disk, it turns out the installation process was a success.
2. The original log file cannot be recorded as plain text, attached is screenshot of the error. I'm willing to provide more information if necessary.

Comment 5 Radek Vykydal 2016-04-14 12:33:06 UTC
*** Bug 1327138 has been marked as a duplicate of this bug. ***

Comment 8 Radek Vykydal 2016-07-18 12:24:33 UTC
*** Bug 1317654 has been marked as a duplicate of this bug. ***

Comment 9 Trinh Dao 2016-08-10 14:05:28 UTC
Hi Joe,
is this bug fix in RHEL7.3 Alpha?

Comment 10 Joseph Kachuck 2016-08-10 16:36:12 UTC
Hello,
anaconda-21.48.22.81-1.el7 was shipped with Alpha. This should have the fix for this issue included.

Thank You
Joe Kachuck

Comment 15 errata-xmlrpc 2016-11-03 23:09:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html


Note You need to log in before you can comment on or make changes to this bug.