This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1255307 - sanlk-resetd runs as unconfined_service_t
sanlk-resetd runs as unconfined_service_t
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
24
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vit Mojzis
Fedora Extras Quality Assurance
:
Depends On: 1212324
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 05:08 EDT by Lukas Vrabec
Modified: 2016-03-23 12:55 EDT (History)
8 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-147.fc24 selinux-policy-3.13.1-179.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1212324
Environment:
Last Closed: 2016-03-23 12:55:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Vrabec 2015-08-20 05:08:04 EDT
+++ This bug was initially created as a clone of Bug #1212324 +++

Description of problem:
 * sanlk-resetd is not yet confined

Version-Release number of selected component (if applicable):
sanlk-reset-3.2.2-2.el7.x86_64
sanlock-3.2.2-2.el7.x86_64
sanlock-lib-3.2.2-2.el7.x86_64
sanlock-python-3.2.2-2.el7.x86_64
selinux-policy-3.13.1-24.el7.noarch
selinux-policy-devel-3.13.1-24.el7.noarch
selinux-policy-doc-3.13.1-24.el7.noarch
selinux-policy-minimum-3.13.1-24.el7.noarch
selinux-policy-mls-3.13.1-24.el7.noarch
selinux-policy-sandbox-3.13.1-24.el7.noarch
selinux-policy-targeted-3.13.1-24.el7.noarch

How reproducible:
always

Steps to Reproduce:
# ps -efZ | grep reset
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 3228 1900  0 09:35 pts/0 00:00:00 grep --color=auto reset
# service sanlk-resetd start
Redirecting to /bin/systemctl start  sanlk-resetd.service
# ps -efZ | grep reset
system_u:system_r:unconfined_service_t:s0 root 3247 1  0 09:35 ?       00:00:00 /usr/sbin/sanlk-resetd
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 3251 1900  0 09:35 pts/0 00:00:00 grep --color=auto reset
# service sanlk-resetd status
Redirecting to /bin/systemctl status  sanlk-resetd.service
sanlk-resetd.service - daemon for host reset
   Loaded: loaded (/usr/lib/systemd/system/sanlk-resetd.service; disabled)
   Active: active (running) since Thu 2015-04-16 09:35:13 CEST; 34s ago
  Process: 3246 ExecStart=/usr/sbin/sanlk-resetd (code=exited, status=0/SUCCESS)
 Main PID: 3247 (sanlk-resetd)
   CGroup: /system.slice/sanlk-resetd.service
           └─3247 /usr/sbin/sanlk-resetd

Apr 16 09:35:13 rhel71.localdomain systemd[1]: Started daemon for host reset.
Apr 16 09:35:13 rhel71.localdomain sanlk-resetd[3247]: sanlk-resetd 3.2.2 sta...
Hint: Some lines were ellipsized, use -l to show in full.
#

Actual results:
 * sanlk-resetd runs as unconfined_service_t

Expected results:
 * sanlk-resetd runs in a dedicated domain

--- Additional comment from Miroslav Grepl on 2015-04-22 04:09:23 EDT ---

Does it come from the base installation?

--- Additional comment from Milos Malik on 2015-04-22 04:16:45 EDT ---

# rpm -qf /usr/sbin/sanlk-resetd
sanlk-reset-3.2.2-2.el7.x86_64
# repoquery -qi sanlk-reset

Name        : sanlk-reset
Version     : 3.2.2
Release     : 2.el7
Architecture: x86_64
Size        : 46119
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Group       : System Environment/Base
URL         : https://fedorahosted.org/sanlock/
Repository  : RHEL-7.1-Server-Optional
Summary     : Host reset daemon and client using sanlock
Source      : sanlock-3.2.2-2.el7.src.rpm
Description :
The sanlk-reset package contains the reset daemon and client.
A cooperating host running the daemon can be reset by a host
running the client, so long as both maintain access to a
common sanlock lockspace.
#
Comment 1 Lukas Vrabec 2015-09-10 04:37:45 EDT
commit c8c0d5ff3aafe606d9aeb05c4f9ab850bf2da66e
Author: Vit Mojzis <vmojzis@redhat.com>
Date:   Thu Sep 10 10:27:59 2015 +0200

    Sanlock policy update. #1255307
      - New sub-domain for sanlk-reset daemon
Comment 2 Jan Kurik 2016-02-24 10:50:47 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Fedora Update System 2016-03-11 04:55:56 EST
selinux-policy-3.13.1-178.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1350c96015
Comment 4 Fedora Update System 2016-03-11 14:25:40 EST
selinux-policy-3.13.1-178.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1350c96015
Comment 5 Fedora Update System 2016-03-16 09:41:44 EDT
selinux-policy-3.13.1-179.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8f142bb969
Comment 6 Fedora Update System 2016-03-18 10:58:31 EDT
selinux-policy-3.13.1-179.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8f142bb969
Comment 7 Fedora Update System 2016-03-23 12:54:36 EDT
selinux-policy-3.13.1-179.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.