Bug 1255315 - [conn] Cannot prepare internal mirrorlist: Curl error (56)
[conn] Cannot prepare internal mirrorlist: Curl error (56)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 05:33 EDT by Kamichr
Modified: 2015-10-28 03:26 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-28 03:26:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested information of comment 1 (23.58 KB, text/plain)
2015-09-07 10:42 EDT, Kamichr
no flags Details

  None (edit)
Description Kamichr 2015-08-20 05:33:35 EDT
Description of problem:

Since the last update of dnf I'm unable to update the metadata. There is a transparent proxy system in our network environment. Maybe this is the main cause for my problem. In addition I edited all repo files under /etc/yum.repos.d/ to not use https as our network department do some man-in-the-middle things. I always hav trouble with https.

Now the issue:

[root@nafe-develop ~]# LIBREPO_DEBUG=1 && dnf -v update
cachedir: /var/cache/dnf
Loaded plugins: repomanage, config-manager, migrate, langpacks, noroot, debuginfo-install, protected_packages, generate_completion_cache, builddep, download, kickstart, reposync, Query, copr, playground, needs-restarting
langpacks: No languages are enabled
initialized Langpacks plugin
DNF version: 1.1.0
Fehler: Zwischenspeicher für Paketquelle »fedora« von »http://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64« kann nicht synchronisiert werden: Cannot prepare internal mirrorlist: Curl error (56): Failure when receiving data from the peer for http://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64 [Recv failure: Die Verbindung wurde vom Kommunikationspartner zurückgesetzt]


yum-deprecated works fine:

[root@nafe-develop ~]# yum-deprecated -v update
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

»tidy-cache«-Plugin wird geladen
Config time: 0.007
tidy-cache.py rev1233, Copyright (c) 2008-2009 Darwin Slattery
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under certain conditions.
For details read the plugin help documentation.
Yum version: 3.4.3
rpmdb time: 0.000
Alles wird aktualisiert
Aktualisierungsobjekt wird erstellt
Paket-Behälter wird eingerichtet
fedora/22/x86_64/metalink                                                                                                                                        |  22 kB  00:00:00     
fedora                                                                                                                                                           | 3.8 kB  00:00:00     
updates/22/x86_64/metalink                                                                                                                                       |  20 kB  00:00:00     
Using older repomd.xml
  Latest: Tue Aug 18 01:53:16 2015
  Using: Wed Aug 19 05:00:38 2015
updates                                                                                                                                                          | 4.9 kB  00:00:00     
(1/4): fedora/22/x86_64/group_gz                                                                                                                                 | 230 kB  00:00:00     
(2/4): updates/22/x86_64/group_gz                                                                                                                                | 230 kB  00:00:00     
(3/4): updates/22/x86_64/primary_db                                                                                                                              | 4.6 MB  00:00:00     
(4/4): fedora/22/x86_64/primary_db                                                                                                                               |  18 MB  00:00:03     
(1/2): updates/22/x86_64/updateinfo                                                                                                                              | 651 kB  00:00:00     
(2/2): updates/22/x86_64/pkgtags                                                                                                                                 | 1.6 MB  00:00:00     
pkgsack time: 9.213
up:Obs Init time: 0.244
up:simple updates time: 0.042
up:obs time: 0.007
up:condense time: 0.000
updates time: 10.163
[...]


Version-Release number of selected component (if applicable):
dnf-1.1.0-2.fc22.noarch
libsolv-0.6.11-2.fc22.x86_64
hawkey-0.6.0-1.fc22.x86_64
rpm-4.12.0.1-12.fc22.x86_64
curl-7.40.0-5.fc22.x86_64


How reproducible:
On my machine every time I start the dnf command


Steps to Reproduce:
1. e.g. sudo dnf update
2.
3.

Actual results:
Curl error (56): Failure when receiving data from the peer


Expected results:
dnf is able to download the metadata

Additional info:
Comment 1 Honza Silhan 2015-09-07 07:01:34 EDT
can you try it with curl only and tell us the result, please?
Comment 2 Kamichr 2015-09-07 10:42:24 EDT
Created attachment 1071048 [details]
Requested information of comment 1

The file include the output of:
date; dnf update; curl -o /tmp/curltest.file "http://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64"; cat /tmp/curltest.file; date
Comment 3 Kamichr 2015-09-07 10:49:03 EDT
One additional comment: I can - without problems - download the link with curl regardless if I use https or not:

WITHOUT:

 cnafe  /  tmp  curl "http://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64"
<?xml version="1.0" encoding="utf-8"?>
<metalink version="3.0" xmlns="http://www.metalinker.org/" type="dynamic" pubdate="Mon, 07 Sep 2015 14:45:05 GMT" generator="mirrormanager" xmlns:mm0="http://fedorahosted.org/mirrormanager">
  <files>
    <file name="repomd.xml">
      <mm0:timestamp>1432376600</mm0:timestamp>
[...]


WITH:

 cnafe  /  tmp  curl "https://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64"
<?xml version="1.0" encoding="utf-8"?>
<metalink version="3.0" xmlns="http://www.metalinker.org/" type="dynamic" pubdate="Mon, 07 Sep 2015 14:45:01 GMT" generator="mirrormanager" xmlns:mm0="http://fedorahosted.org/mirrormanager">
  <files>
    <file name="repomd.xml">
      <mm0:timestamp>1432376600</mm0:timestamp>
Comment 4 Kamichr 2015-09-14 03:17:53 EDT
Meanwhile there were updates for curl and dnf:

rpm -qa | grep -E "^(dnf|libsolv|hawkey|rpm|curl)-[[:digit:]]"
rpm-4.12.0.1-12.fc22.x86_64
hawkey-0.6.0-1.fc22.x86_64
dnf-1.1.1-2.fc22.noarch
libsolv-0.6.11-2.fc22.x86_64
curl-7.40.0-6.fc22.x86_64

But the issue is still there.

As workaround I use yum-deprecated and infrequently gnome-software which both don't have problems.
Comment 5 Kamichr 2015-10-05 06:51:55 EDT
Hi there. Some updates later is all the same:

rpm -q dnf libsolv hawkey rpm curl
dnf-1.1.2-4.fc22.noarch
libsolv-0.6.11-2.fc22.x86_64
hawkey-0.6.1-2.fc22.x86_64
rpm-4.12.0.1-12.fc22.x86_64
curl-7.40.0-7.fc22.x86_64
Comment 6 Kamichr 2015-10-19 01:38:38 EDT
Meanwhile there were updates for dnf, libsolv and hawkey. No changes.

dnf-1.1.3-1.fc22.noarch
libsolv-0.6.14-2.fc22.x86_64
hawkey-0.6.2-1.fc22.x86_64
rpm-4.12.0.1-12.fc22.x86_64
curl-7.40.0-7.fc22.x86_64
Comment 7 Kamichr 2015-10-28 03:26:25 EDT
Strange thing.

Yesterday I started to debug dnf (repo.py) to find the cause for my issue for myself.
During the action I switched back to https in all repo files to see how dnf act different.

What should I say. It works now.

Conclusion:
Without https in the repo files yum-deprecated and gnome-software work.
With https now all tools work.

Maybe the guys from our network department changed a thing. I changed from https to http at the beginning as I was not able to download metadata with any tool on https.

Note You need to log in before you can comment on or make changes to this bug.