Bug 1255325 - SpeedLink strike-fx 6 sixaxis gamepad usb mode broken in kernel 4.1
SpeedLink strike-fx 6 sixaxis gamepad usb mode broken in kernel 4.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 05:43 EDT by The Source
Modified: 2016-02-23 14:49 EST (History)
7 users (show)

See Also:
Fixed In Version: kernel-4.3.5-200.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 14:50:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-HID-sony-do-not-bail-out-when-the-sixaxis-refuses-th.patch (1.57 KB, patch)
2016-01-08 04:39 EST, Benjamin Tissoires
no flags Details | Diff

  None (edit)
Description The Source 2015-08-20 05:43:10 EDT
Description of problem:
When connecting specified gamebad via usb I get the following error:
sony 0003:054C:0268.000B: can't set operational mode: step 3
sony: probe of 0003:054C:0268.000B failed with error -71
This happens at least in 4.1.4-4.1.6. In 4.0.8 gamepad works fine.

Version-Release number of selected component (if applicable):
4.1.6

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 The Source 2015-09-24 05:48:53 EDT
Still broken in 4.1.7
Comment 2 The Source 2015-09-25 02:46:59 EDT
I downloaded 4.1.8 source and commented out lines 1162-1164 in drivers/hid/hid-sony.c:

/*ret = hid_hw_output_report(hdev, buf, 1);
	if (ret < 0)
		hid_err(hdev, "can't set operational mode: step 3\n");*/

After recompiling module gamepad works fine again. Perhaps speedlink gamepad can't process that request properly.
Comment 3 The Source 2015-10-10 08:27:16 EDT
Still broken in 4.2.3
Comment 4 Justin M. Forbes 2015-10-20 15:38:08 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 22 kernel bugs.

Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 23, and are still experiencing this issue, please change the version to Fedora 23.

If you experience different issues, please open a new bug report for those.
Comment 5 The Source 2015-10-20 16:52:36 EDT
As I mentioned, the bug is still present in 4.2.3-200.fc22. The workaround I suggested also works in this version.
Comment 6 The Source 2016-01-08 03:54:07 EST
4.3.3-300.fc23 still there
Comment 7 Benjamin Tissoires 2016-01-08 04:39 EST
Created attachment 1112818 [details]
0001-HID-sony-do-not-bail-out-when-the-sixaxis-refuses-th.patch

Apologies for the delay.

Would you mind testing the attached patch?
If that works, and you are ok with, when I submit this upstream, I'd like to add your "Reported-and-reviewed-by: Your Name <your@adress.sth>".
Comment 8 The Source 2016-01-08 05:14:19 EST
Tested the patch. I get 'sony 0003:054C:0268.0004: can't set operational mode: step 3, ignoring' in dmesg (as expected) and after that controller works just fine, thank you.

Max Fedotov <thesourcehim@gmail.com>
Comment 9 Benjamin Tissoires 2016-01-08 12:00:11 EST
Thanks for the tests.

Patch posted upstream: http://thread.gmane.org/gmane.linux.kernel.input/47590
Comment 10 Benjamin Tissoires 2016-01-29 08:38:22 EST
Just in case, the patch has been included in the for-4.6 branch of the HID tree:
https://git.kernel.org/cgit/linux/kernel/git/jikos/hid.git/commit/drivers/hid/hid-sony.c?h=for-next&id=19f4c2ba869517048add62c202f9645b6adf5dfb

And I think it should be good to backport it in Fedora :)
(Josh, if you are around....)
Comment 11 Josh Boyer 2016-01-29 15:25:43 EST
Backported to all branches.  Thanks!
Comment 12 The Source 2016-02-02 14:50:27 EST
Fixed in 4.3.5-300.fc23
Comment 13 Fedora Update System 2016-02-13 11:17:42 EST
kernel-4.3.5-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-16a5625f33
Comment 14 Fedora Update System 2016-02-23 14:48:49 EST
kernel-4.3.5-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.