Bug 1255357 - Remove the --autofree option from boot.ipxe
Remove the --autofree option from boot.ipxe
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity medium
: z2
: 7.0 (Kilo)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 07:17 EDT by Lucas Alvares Gomes
Modified: 2018-04-16 08:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-ironic-2015.1.1-2.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the '--autofree' parameter was included by default in the boot.ipxe template used by Bare Metal Provisioning (Ironic), but the parameter is not supported on older versions of the iPXE ROM (including v1.0.0, which is the stable release and the one that is packaged with Red Hat Enterprise Linux OpenStack Platform). When those older versions were used to boot nodes, the boot failed. Now, the '--autofree' parameter is not included in the iPXE template by default, and older and newer versions of iPXE are supported using the same template. Nodes using older versions can now boot successfully. Users can still add the '--autofree' parameter manually; it is good practice to use the parameter, but it is not mandatory.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 08:25:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 215074 None None None Never

  None (edit)
Description Lucas Alvares Gomes 2015-08-20 07:17:46 EDT
Description of problem:

Many distros create and distribute images based on the v1.0.0 code from
iPXE (stable release). This version does not support the --autofree flag
that we use in our boot.ipxe template and the boot will fail.

Version-Release number of selected component (if applicable):


How reproducible:

Always if using an stable release of the iPXE image 

Steps to Reproduce:
1. Copy a iPXE ROM built from the v1.0.0 tag to the tftp directory
2. Boot an image
3.

Actual results:

Boot will fail when iPXE try to chainload to the linux kernel

Expected results:

Boot to succeed

Additional info:

While using --autofree may be a good practice (it frees the image after
chainloading) it's not mandatory and by removing it we will get a much
support for people using the stable version of iPXE and it will continue
to work with the images built from the master.
Comment 5 Lucy Bopf 2015-09-16 01:38:29 EDT
NEEDINFO: Lucas

This bug is marked for inclusion in RHBA-2015:21553 [1] but does not currently contain draft documentation text. To ensure the timely release of this advisory, please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".

To add draft documentation text:
* Select the documentation type from the "Doc Type" drop down field.
* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

For further information on this process, refer to "Describing Errata Release and Technical Notes for Engineers" [2]. Thank you for your assistance!

[1] https://errata.devel.redhat.com/advisory/21553
[2] https://engineering.redhat.com/docs/en-US/Policy/70.ecs/html/Describing_Errata_Release_and_Technical_Notes_for_Engineers/index.html
Comment 7 Lucas Alvares Gomes 2015-10-05 10:13:46 EDT
Hi Lucinda,

I think that it would be good to include this bug in the advisory text as far as I understand it (do we have a guide about what should be included and what not ? ).
Comment 10 errata-xmlrpc 2015-10-08 08:25:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1864

Note You need to log in before you can comment on or make changes to this bug.