Bug 1255371 - pkcon - gstreamer-plugin - unable to install video codec
pkcon - gstreamer-plugin - unable to install video codec
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: PackageKit (Show other bugs)
7.2
Unspecified Linux
unspecified Severity urgent
: beta
: ---
Assigned To: Richard Hughes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 07:51 EDT by Ladislav Kolacek
Modified: 2015-08-26 04:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 10:11:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
MessageBox.png (66.07 KB, image/png)
2015-08-20 07:51 EDT, Ladislav Kolacek
no flags Details

  None (edit)
Description Ladislav Kolacek 2015-08-20 07:51:50 EDT
Created attachment 1065217 [details]
MessageBox.png

Description of problem:
Test case failure: https://tcms.engineering.redhat.com/case/221793/?from_plan=18766

Version-Release number of selected component (if applicable):
PackageKit-1.0.7-4.el7.ppc64
kernel-3.10.0-305.el7.ppc64

How reproducible:
100%

Steps to Reproduce:
1. obtain webm video (you can record it via ctrl+shift+alt+r in gnome shell)
2. remove libvpx via rpm -e libvpx --nodeps
3. double click webm video in nautilus
4. when totem opens click search missing codec

Actual results:
Message box with error message appears - "Failed to search for plugin" (see attachment)

Expected results:
You should be able to install missing codec and play video

Additional info:
Problem appeared on architectures: ppc64, ppc64le
Comment 1 Richard Hughes 2015-08-25 10:11:02 EDT
GNOME Software won't just install any random codec-related package if it's been removed, and certainly won't fix up issues caused by using nodeps. We're only going to find the gstreamer codec packs as that's all we've got the metadata for. I'm guessing this actually works if you remove something like gstreamer-plugins-bad and then try to play it.
Comment 2 Ladislav Kolacek 2015-08-26 04:17:16 EDT
I removed gstreamer1-plugins-bad and gstreamer-plugins-bad. It had no effect on playing video.

Note You need to log in before you can comment on or make changes to this bug.