Bug 1255398 - isolinux boot fails with syslinux version 6.03 (rescue image made by rear)
isolinux boot fails with syslinux version 6.03 (rescue image made by rear)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 09:21 EDT by Gratien D'haese
Modified: 2015-09-25 14:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 14:17:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gratien D'haese 2015-08-20 09:21:00 EDT
Description of problem: Booting the rescue ISO image made by rear hangs with Fedora 23 (alpha) - it does work on previous versions and other new distro's using syslinux > 6


Version-Release number of selected component (if applicable): syslinux-6.03


How reproducible:
download rear snapshot from http://download.opensuse.org/repositories/Archiving:/Backup:/Rear:/Snapshot/Fedora_22/noarch/
(however, OBS seems to have some serious problems as it cannot build rpms right now - 500: Internal Server Error). 
You can use git clone git@github.com:rear/rear.git
and execute make rpm

# rear -v mkrescue
# cat /etc/rear/site.conf
OUTPUT=ISO
BACKUP=NETFS
BACKUP_URL=nfs://nfsserver.com/linux_images_dr/rear

# isoinfo -d -i /var/lib/rear/output/rear-localhost.iso
CD-ROM is in ISO 9660 format
System id: LINUX
Volume id: RELAXRECOVER
Volume set id:
Publisher id:
Data preparer id:
Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993 E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT TEAM
Copyright File id:
Abstract File id:
Bibliographic File id:
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 65968
El Torito VD version 1 found, boot catalog is in sector 41
Joliet with UCS level 3 found
Rock Ridge signatures version 1 found
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID ''
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 4
        Bootoff 2A 42
Steps to Reproduce:
1. install rear
2. cp /usr/share/syslinux/isolinux-debug.bin /usr/share/syslinux/isolinux.bin
2. run rear -v mkrescue
3. boot from the ISO image /var/lib/rear/output/rear-$(hostname).iso

Actual results:
Booting from DVD/CD...

ISOLINUX 6.03  Copyright (C) 1994-2014 H. Peter Anvin et al
isolinux: Starting up, DL = E0
isolinux: Loaded spec packet OK, drive = E0
isolinux: Main image LBA = 0000002B
isolinux: Image read, jumping to main code...

Expected results:
booting up the rescue image to a fully login prompt
Same code works perfectly on F22 (but that one is using an older syslinux)

Additional info:
- syslinux 6.03 needs the ldlinux.c32 additional with the isolinux.bin
- I even tested with all files included from /usr/share/syslinux, but with the same result:
# isoinfo -f -i /var/lib/rear/output/rear-localhost.iso
/ISOLINUX
/ISOLINUX/ALTMBR.BIN;1
/ISOLINUX/ALTMBR_C.BIN;1
/ISOLINUX/ALTMBR_F.BIN;1
/ISOLINUX/BOOT.CAT;1
/ISOLINUX/CAT.C32;1
/ISOLINUX/CHAIN.C32;1
/ISOLINUX/CMD.C32;1
/ISOLINUX/CMENU.C32;1
/ISOLINUX/CONFIG.C32;1
/ISOLINUX/CPTIME.C32;1
/ISOLINUX/CPU.C32;1
/ISOLINUX/CPUID.C32;1
/ISOLINUX/CPUIDTEST.C32;1
/ISOLINUX/DEBUG.C32;1
/ISOLINUX/DHCP.C32;1
/ISOLINUX/DISK.C32;1
/ISOLINUX/DMI.C32;1
/ISOLINUX/DMITEST.C32;1
/ISOLINUX/ELF.C32;1
/ISOLINUX/ETHERSEL.C32;1
/ISOLINUX/GFXBOOT.C32;1
/ISOLINUX/GPTMBR.BIN;1
/ISOLINUX/GPTMBR_C.BIN;1
/ISOLINUX/GPTMBR_F.BIN;1
/ISOLINUX/GPXECMD.C32;1
/ISOLINUX/GPXELINUX.0;1
/ISOLINUX/GPXELINUXK.0;1
/ISOLINUX/HDT.C32;1
/ISOLINUX/HEXDUMP.C32;1
/ISOLINUX/HOST.C32;1
/ISOLINUX/IFCPU.C32;1
/ISOLINUX/IFCPU64.C32;1
/ISOLINUX/IFMEMDSK.C32;1
/ISOLINUX/IFPLOP.C32;1
/ISOLINUX/INITRD.CGZ;1
/ISOLINUX/ISOHDPFX.BIN;1
/ISOLINUX/ISOHDPFX_C.BIN;1
/ISOLINUX/ISOHDPFX_F.BIN;1
/ISOLINUX/ISOHDPPX.BIN;1
/ISOLINUX/ISOHDPPX_C.BIN;1
/ISOLINUX/ISOHDPPX_F.BIN;1
/ISOLINUX/ISOLINUX.BIN;1
/ISOLINUX/ISOLINUX.CFG;1
/ISOLINUX/ISOLINUX_NODEBUG.BIN;1
/ISOLINUX/KBDMAP.C32;1
/ISOLINUX/KERNEL.;1
/ISOLINUX/KONTRON_WDT.C32;1
/ISOLINUX/LDLINUX.C32;1
/ISOLINUX/LFS.C32;1
/ISOLINUX/LIBCOM32.C32;1
/ISOLINUX/LIBGPL.C32;1
/ISOLINUX/LIBLUA.C32;1
/ISOLINUX/LIBMENU.C32;1
/ISOLINUX/LIBUTIL.C32;1
/ISOLINUX/LINUX.C32;1
/ISOLINUX/LPXELINUX.0;1
/ISOLINUX/LS.C32;1
/ISOLINUX/LUA.C32;1
/ISOLINUX/MBOOT.C32;1
/ISOLINUX/MBR.BIN;1
/ISOLINUX/MBR_C.BIN;1
/ISOLINUX/MBR_F.BIN;1
/ISOLINUX/MEMDISK.;1
/ISOLINUX/MEMINFO.C32;1
/ISOLINUX/MENU.C32;1
/ISOLINUX/MESSAGE.;1
/ISOLINUX/PCI.C32;1
/ISOLINUX/PCI.IDS;1
/ISOLINUX/PCITEST.C32;1
/ISOLINUX/PMLOAD.C32;1
/ISOLINUX/POWEROFF.C32;1
/ISOLINUX/PRDHCP.C32;1
/ISOLINUX/PWD.C32;1
/ISOLINUX/PXECHN.C32;1
/ISOLINUX/PXELINUX.0;1
/ISOLINUX/REAR.HELP;1
/ISOLINUX/REBOOT.C32;1
/ISOLINUX/ROSH.C32;1
/ISOLINUX/SANBOOT.C32;1
/ISOLINUX/SDI.C32;1
/ISOLINUX/SYSDUMP.C32;1
/ISOLINUX/SYSLINUX.C32;1
/ISOLINUX/SYSLINUX.COM;1
/ISOLINUX/SYSLINUX.EXE;1
/ISOLINUX/SYSLINUX64.EXE;1
/ISOLINUX/VESA.C32;1
/ISOLINUX/VESAINFO.C32;1
/ISOLINUX/VESAMENU.C32;1
/ISOLINUX/VPDTEST.C32;1
/ISOLINUX/WHICHSYS.C32;1
/ISOLINUX/ZZJSON.C32;1

See also rear issue https://github.com/rear/rear/issues/636
Comment 1 Gratien D'haese 2015-09-25 14:17:54 EDT
Problem seems to be fixed in Fedora 23 beta - whatever changed - thank you.

Note You need to log in before you can comment on or make changes to this bug.