Bug 1255452 - fedora-easy-karma doesn't work after Bodhi 2 update
Summary: fedora-easy-karma doesn't work after Bodhi 2 update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-easy-karma
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1258079 1259492 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-20 15:30 UTC by Couret Charles-Antoine
Modified: 2015-11-13 19:26 UTC (History)
14 users (show)

Fixed In Version: fedora-easy-karma-0-0.26.20150921gitc932687a.fc22 fedora-easy-karma-0-0.26.20150921gitc932687a.fc23 fedora-easy-karma-0-0.26.20150921gitc932687a.fc21 fedora-easy-karma-0-0.26.20150921gitc932687a.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-03 21:15:17 UTC
Type: Bug


Attachments (Terms of Use)
patch to make fedora-easy-karma work with bodhi2 (8.54 KB, patch)
2015-08-24 16:53 UTC, Tim Flink
no flags Details | Diff
updated patch to make f-e-k work with bodhi2 (8.54 KB, patch)
2015-09-14 16:42 UTC, Tim Flink
no flags Details | Diff

Description Couret Charles-Antoine 2015-08-20 15:30:09 UTC
When I launched fedora-easy-karma, I have the following error before close the application automatically :

[17:17:01] Renault@Ducky:~$ fedora-easy-karma --fas-username=renault
Getting list of installed packages...
Waiting for Bodhi for a list of packages in updates-testing (F22)...
Cannot query Bodhi: 1000 is greater than maximum value 100

Today, Bodhi was updates to version 2.
I updated python-fedora package to 0.5.5-1.fc22

Before that, I don't have any problem with this software after several months...

Comment 1 Jiri Popelka 2015-08-21 10:30:27 UTC
Same with F23:
fedora-easy-karma-0-0.25.20150508gitc8e437c0.fc23.noarch
python-fedora-0.5.5-1.fc23.noarch

Comment 2 Ankur Sinha (FranciscoD) 2015-08-21 10:35:27 UTC
Confirming.

Comment 3 Tim Flink 2015-08-24 16:53:49 UTC
Created attachment 1066539 [details]
patch to make fedora-easy-karma work with bodhi2

I'm waiting for some more information from the bodhi devs before considering it done but I have a patch which seems to be working for me. Test case rendering is currently disabled until a bodhi issue [1] is clarified and resolved.

I've attached the patch to this bug - feedback is welcome

[1] https://github.com/fedora-infra/bodhi/issues/270

Comment 4 Jiri Popelka 2015-08-25 08:56:59 UTC
Works for me too, thanks.

Comment 5 Jiri Popelka 2015-08-26 08:59:19 UTC
When I run fedora-easy-karma today I noticed that it offers me to evaluate updates that I already evaluated (with '1', i.e. positive karma) yesterday.
I'm using the patch from comment #3.

Comment 6 Yu Watanabe 2015-08-29 07:14:08 UTC
I noticed that --no-skip-empty-comment option does not work.

Comment 7 Till Maas 2015-09-02 22:02:42 UTC
*** Bug 1259492 has been marked as a duplicate of this bug. ***

Comment 8 Till Maas 2015-09-02 22:03:21 UTC
*** Bug 1258079 has been marked as a duplicate of this bug. ***

Comment 9 Tim Flink 2015-09-14 16:35:53 UTC
(In reply to Yu Watanabe from comment #6)
> I noticed that --no-skip-empty-comment option does not work.

Did that work before the upgrade to bodhi2? I don't see anything in the new bodhi2 stuff that would affect that functionality

Comment 10 Tim Flink 2015-09-14 16:36:42 UTC
(In reply to Jiri Popelka from comment #5)
> When I run fedora-easy-karma today I noticed that it offers me to evaluate
> updates that I already evaluated (with '1', i.e. positive karma) yesterday.
> I'm using the patch from comment #3.

Thanks for mentioning this - I missed that part of the code but the next diff will get that working again

Comment 11 Tim Flink 2015-09-14 16:42:42 UTC
Created attachment 1073344 [details]
updated patch to make f-e-k work with bodhi2

I've updated the patch to address some of the feedback and work around some issues. I'm not aware of any remaining issues and should be push-able to get f-e-k working without requiring patches.

Comment 12 Tim Flink 2015-09-14 16:45:10 UTC
Note that the retry logic in the bodhi client is currently not working. This won't affect the comment retry logic but I have been seeing some failures while pulling down update information.

The issue for bodhi client retry logic has been filed upstream:
https://github.com/fedora-infra/python-fedora/issues/144

Comment 13 Yu Watanabe 2015-09-15 03:02:28 UTC
(In reply to Tim Flink from comment #9)
> (In reply to Yu Watanabe from comment #6)
> > I noticed that --no-skip-empty-comment option does not work.
> 
> Did that work before the upgrade to bodhi2? I don't see anything in the new
> bodhi2 stuff that would affect that functionality

Yes, it worked for me before the upgrade to bodhi2.

Comment 14 Jiri Popelka 2015-09-15 09:52:10 UTC
(In reply to Tim Flink from comment #11)
> Created attachment 1073344 [details]
> updated patch to make f-e-k work with bodhi2

Works OK for me.

Comment 15 Fedora Update System 2015-09-22 16:34:55 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16437

Comment 16 Fedora Update System 2015-09-22 16:35:05 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8194

Comment 17 Fedora Update System 2015-09-22 16:35:14 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16439

Comment 18 Fedora Update System 2015-09-23 03:54:14 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update fedora-easy-karma'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16437

Comment 19 Fedora Update System 2015-09-23 05:22:46 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update fedora-easy-karma'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16438

Comment 20 Fedora Update System 2015-09-23 08:52:23 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update fedora-easy-karma'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8194

Comment 21 Fedora Update System 2015-09-23 21:22:07 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update fedora-easy-karma'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16439

Comment 22 Fedora Update System 2015-10-03 21:15:12 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2015-11-12 23:30:21 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2015-11-13 02:52:34 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2015-11-13 19:26:19 UTC
fedora-easy-karma-0-0.26.20150921gitc932687a.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.