Bug 1255453 - Typo in a template should be better reported
Typo in a template should be better reported
Status: CLOSED DUPLICATE of bug 1246596
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: y2
: 7.0 (Kilo)
Assigned To: RHOS Maint
yeylon@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 11:30 EDT by David Juran
Modified: 2016-04-18 02:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 12:41:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2015-08-20 11:30:17 EDT
Description of problem:
If there is a typo in one of the templates describing the overcloud, the error message isn't overly helpful:

$ 
openstack overcloud deploy --templates ~/my_templates/ \
>    --ntp-server 10.5.26.10 \
>     --control-flavor control --compute-flavor compute --ceph-storage-flavor ceph \
>     --control-scale 3 --compute-scale 1 --ceph-storage-scale 3 \
>     --neutron-tunnel-types vxlan --neutron-network-type vxlan \
>     -e ~/my_templates/environments/storage-environment.yaml \
>     -e ~/my_templates/advanced-networking.yaml \
>     -e ~/my_templates/firstboot-environment.yaml
Deploying templates in the directory /home/stack/my_templates
ERROR: openstack ERROR: Failed to validate: Failed to validate: Error parsing template: while scanning a simple key
  in "<unicode string>", line 21, column 1
could not find expected ':'
  in "<unicode string>", line 22, column 1

At least the file where the error occurred would be nice.

Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.8-44.el7ost
Comment 3 chris alfonso 2015-08-26 12:41:17 EDT
We'll work on this validation as part of the validation suite

*** This bug has been marked as a duplicate of bug 1246596 ***

Note You need to log in before you can comment on or make changes to this bug.