Bug 1255455 - [abrt] [master] [beaker] NetworkManager: g_type_check_instance_cast(): NetworkManager killed by SIGSEGV
[abrt] [master] [beaker] NetworkManager: g_type_check_instance_cast(): Networ...
Status: CLOSED DUPLICATE of bug 1253407
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager (Show other bugs)
7.3
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rashid Khan
Desktop QE
abrt_hash:f37c2ba0d28c09ba11c6c7802e0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 11:42 EDT by Lubomir Rintel
Modified: 2015-08-20 12:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-20 12:30:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (26.94 KB, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: cgroup (199 bytes, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: core_backtrace (10.58 KB, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: dso_list (5.81 KB, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: environ (72 bytes, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: machineid (135 bytes, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: maps (26.54 KB, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: open_fds (12.66 KB, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: proc_pid_status (1.03 KB, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details
File: var_log_messages (39.80 KB, text/plain)
2015-08-20 11:42 EDT, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2015-08-20 11:42:37 EDT
Description of problem:
Beaker run:

https://beaker.engineering.redhat.com/jobs/1056014

Logs:

Aug 20 09:11:52 myown.hostname nmcli/./runtest.sh[17631]: Running test team_activate
...
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <info>  (eth1): Activation: connection 'team0.0' enslaved, continuing activation
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.186257] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe60768b8a0] (eth1): add_pending_action (3): 'queued state change t
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.186271] [devices/nm-device.c:8853] nm_device_queue_state(): [0x7fe60768b8a0] (eth1): queued state change to secondaries due to none (id 22
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265287] [devices/nm-device.c:8922] nm_device_update_hw_address(): [0x7fe607dd07b0] (nm-team): hardware address now 52:54:00:DD:38:B4
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265441] [devices/nm-device.c:5410] nm_device_activate_stage3_ip_config_start(): [0x7fe60768b8a0] (eth1): Activation: Stage 3 of 5 (IP Conf
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265709] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe60764d920] (eth10): add_pending_action (1): 'autoactivate'
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265751] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe6076588a0] (eth5): add_pending_action (1): 'autoactivate'
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265782] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe607661aa0] (eth7): add_pending_action (1): 'autoactivate'
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265813] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe60766aea0] (eth2): add_pending_action (1): 'autoactivate'
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265843] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe607679590] (eth9): add_pending_action (1): 'autoactivate'
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265871] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe6076826a0] (eth4): add_pending_action (1): 'autoactivate'
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265899] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe6076946a0] (eth6): add_pending_action (1): 'autoactivate'
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265927] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe60769f0a0] (eth8): add_pending_action (1): 'autoactivate'
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.265955] [devices/nm-device.c:7993] nm_device_add_pending_action(): [0x7fe6076a7fd0] (eth3): add_pending_action (1): 'autoactivate'
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.280121] [nm-exported-object.c:571] idle_emit_properties_changed(): PropertiesChanged NMIfcfgConnection 0x7fe607603c30: {'Unsaved': <false>
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.280265] [settings/nm-agent-manager.c:599] request_next_agent(): (x:y:216/nmcli-connect/0) agent saving secrets for request 0x7fe607dd26d0/
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.280477] [nm-exported-object.c:571] idle_emit_properties_changed(): PropertiesChanged NMDeviceTeam 0x7fe607dd07b0: {'State': <uint32 50>, '
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.280628] [nm-firewall-manager.c:104] _cb_info_complete_and_free(): (nm-team) firewall zone idle call succeeded [47]
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.280648] [devices/nm-device.c:5434] fw_change_zone_cb(): [0x7fe607dd07b0] (nm-team): Activation: Stage 3 of 5 (IP Configure Start) schedule
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.282150] [settings/nm-agent-manager.c:98] remove_agent(): (x:y:216/nmcli-connect/0) agent unregistered or disappeared
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.282169] [settings/nm-agent-manager.c:624] request_remove_agent(): (x:y:216/nmcli-connect/0) current agent removed from secrets request 0x7
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.282347] [nm-dispatcher.c:359] dispatcher_results_process(): (134) 00-netreport succeeded
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.282365] [nm-dispatcher.c:359] dispatcher_results_process(): (134) 10-ifcfg-rh-routes.sh succeeded
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.282378] [nm-dispatcher.c:359] dispatcher_results_process(): (134) 11-dhclient succeeded
Aug 20 09:12:22 myown.hostname kernel: traps: NetworkManager[8608] general protection ip:7fe602d04ef0 sp:7ffe3157ce70 error:0 in libgobject-2.0.so.0.4200.2[7fe602cd3000+4e000]
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.282389] [nm-dispatcher.c:359] dispatcher_results_process(): (134) 12-dhcpd succeeded
Aug 20 09:12:22 myown.hostname NetworkManager[8608]: <debug> [1440076342.289268] [nm-dispatcher.c:359] dispatcher_results_process(): (134) 20-chrony succeeded
Aug 20 09:12:22 myown.hostname nm-dispatcher[17751]: Script '/etc/NetworkManager/dispatcher.d/00-netreport' complete
Aug 20 09:12:22 myown.hostname nm-dispatcher[17751]: Running script '/etc/NetworkManager/dispatcher.d/10-ifcfg-rh-routes.sh'
Aug 20 09:12:23 myown.hostname nm-dispatcher[17751]: Script '/etc/NetworkManager/dispatcher.d/10-ifcfg-rh-routes.sh' complete   
Aug 20 09:12:23 myown.hostname nm-dispatcher[17751]: Running script '/etc/NetworkManager/dispatcher.d/11-dhclient'
Aug 20 09:12:24 myown.hostname systemd[1]: NetworkManager.service: main process exited, code=dumped, status=11/SEGV

Version-Release number of selected component:
NetworkManager-1.1.0-12838.ad7cdfc766.el7.centos

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: g_type_check_instance_cast
executable:     /usr/sbin/NetworkManager
kernel:         3.10.0-302.el7.x86_64
runlevel:       N 3
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (9 frames)
 #0 g_type_check_instance_cast at gtype.c:4013
 #1 nmdbus_secret_agent_call_save_secrets_finish at nmdbus-secret-agent.c:943
 #2 agent_save_cb at settings/nm-secret-agent.c:371
 #3 g_simple_async_result_complete at gsimpleasyncresult.c:763
 #4 reply_cb at gdbusproxy.c:2623
 #5 g_simple_async_result_complete at gsimpleasyncresult.c:763
 #6 g_dbus_connection_call_done at gdbusconnection.c:5502
 #7 g_simple_async_result_complete at gsimpleasyncresult.c:763
 #8 complete_in_idle_cb at gsimpleasyncresult.c:775
Comment 1 Lubomir Rintel 2015-08-20 11:42:39 EDT
Created attachment 1065316 [details]
File: backtrace
Comment 2 Lubomir Rintel 2015-08-20 11:42:40 EDT
Created attachment 1065317 [details]
File: cgroup
Comment 3 Lubomir Rintel 2015-08-20 11:42:41 EDT
Created attachment 1065318 [details]
File: core_backtrace
Comment 4 Lubomir Rintel 2015-08-20 11:42:42 EDT
Created attachment 1065319 [details]
File: dso_list
Comment 5 Lubomir Rintel 2015-08-20 11:42:43 EDT
Created attachment 1065320 [details]
File: environ
Comment 6 Lubomir Rintel 2015-08-20 11:42:44 EDT
Created attachment 1065321 [details]
File: limits
Comment 7 Lubomir Rintel 2015-08-20 11:42:45 EDT
Created attachment 1065322 [details]
File: machineid
Comment 8 Lubomir Rintel 2015-08-20 11:42:46 EDT
Created attachment 1065323 [details]
File: maps
Comment 9 Lubomir Rintel 2015-08-20 11:42:47 EDT
Created attachment 1065324 [details]
File: open_fds
Comment 10 Lubomir Rintel 2015-08-20 11:42:48 EDT
Created attachment 1065325 [details]
File: proc_pid_status
Comment 11 Lubomir Rintel 2015-08-20 11:42:49 EDT
Created attachment 1065326 [details]
File: var_log_messages
Comment 13 Thomas Haller 2015-08-20 12:28:03 EDT
I think this is a dupe of bug 1253407.

See branch th/secret-agent-rh1253407
Comment 14 Thomas Haller 2015-08-20 12:30:32 EDT
Hm... IMO handling of the async data in NMSecretAgent is seriously messed up.

I dupe this to bug 1253407.

*** This bug has been marked as a duplicate of bug 1253407 ***

Note You need to log in before you can comment on or make changes to this bug.