Bug 1255463 - RFE: When strict=false not removing the running kernel shouldn't block all of the potential transaction
RFE: When strict=false not removing the running kernel shouldn't block all of...
Status: CLOSED DUPLICATE of bug 1253264
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
futurefeature
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 11:59 EDT by Bruno Wolff III
Modified: 2015-08-31 09:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 09:50:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2015-08-20 11:59:20 EDT
Description of problem:
When doing distro-sync --allowerasing, if this would remove the running kernel then the whole transaction will fail. This is a useful command for upgrading between Fedora releases (though not officially supported) and it would be nice if that when strict=false that removing the running kernel packages would be skipped, but that as much as possible of the remaining parts of the transaction would still be processed.

Here is a short example in a normal update case:
[root@cerberus bruno]# dnf distro-sync --allowerasing
Failed loading plugin: spacewalk
Last metadata expiration check performed 0:01:58 ago on Thu Aug 20 10:38:54 2015.
Dependencies resolved.
Error: The operation would result in removing the booted kernel: kernel-core-4.2.0-0.rc7.git0.1.fc23.x86_64.
[root@cerberus bruno]# dnf distro-sync
Failed loading plugin: spacewalk
Last metadata expiration check performed 0:02:06 ago on Thu Aug 20 10:38:54 2015.
Dependencies resolved.
================================================================================
 Package                  Arch   Version                  Repository       Size
================================================================================
Installing:
 kernel                   x86_64 4.2.0-0.rc7.git2.1.fc24  fedora-rawhide-kernel-nodebug
                                                                           73 k
 kernel-core              x86_64 4.2.0-0.rc7.git2.1.fc24  fedora-rawhide-kernel-nodebug
                                                                           20 M
 kernel-devel             x86_64 4.2.0-0.rc7.git2.1.fc24  fedora-rawhide-kernel-nodebug
                                                                          9.9 M
 kernel-modules           x86_64 4.2.0-0.rc7.git2.1.fc24  fedora-rawhide-kernel-nodebug
                                                                           18 M
 kernel-modules-extra     x86_64 4.2.0-0.rc7.git2.1.fc24  fedora-rawhide-kernel-nodebug
                                                                          2.2 M
Upgrading:
 kernel-headers           x86_64 4.2.0-0.rc7.git2.1.fc24  fedora-rawhide-kernel-nodebug
                                                                          1.0 M
 mariadb                  x86_64 1:10.0.21-1.fc23         fedora          6.0 M
 mariadb-common           x86_64 1:10.0.21-1.fc23         fedora           74 k
 mariadb-config           x86_64 1:10.0.21-1.fc23         fedora           25 k
 mariadb-devel            x86_64 1:10.0.21-1.fc23         fedora          867 k
 mariadb-embedded         x86_64 1:10.0.21-1.fc23         fedora          4.0 M
 mariadb-errmsg           x86_64 1:10.0.21-1.fc23         fedora          199 k
 mariadb-libs             x86_64 1:10.0.21-1.fc23         fedora          637 k
 mariadb-server           x86_64 1:10.0.21-1.fc23         fedora           18 M
 python-fedora            noarch 0.5.5-1.fc23             updates-testing 281 k
 python-fedora-turbogears noarch 0.5.5-1.fc23             updates-testing  59 k
Downgrading:
 device-mapper-multipath  x86_64 0.4.9-76.fc23            fedora          118 k
 device-mapper-multipath-libs
                          x86_64 0.4.9-76.fc23            fedora          218 k
 kernel-tools             x86_64 4.2.0-0.rc6.git0.2.fc23  updates-testing 160 k
 kernel-tools-libs        x86_64 4.2.0-0.rc6.git0.2.fc23  updates-testing  79 k
 kernel-tools-libs-devel  x86_64 4.2.0-0.rc6.git0.2.fc23  updates-testing  76 k
 kpartx                   x86_64 0.4.9-76.fc23            fedora           60 k

Transaction Summary
================================================================================
Install     5 Packages
Upgrade    11 Packages
Downgrade   6 Packages

Total size: 82 M
Is this ok [y/N]: n
Operation aborted.
Comment 1 Honza Silhan 2015-08-31 09:50:18 EDT
I believe this dup of bug 1253264. I'd rather fix it the way it would remove the oldest non running by default.

*** This bug has been marked as a duplicate of bug 1253264 ***

Note You need to log in before you can comment on or make changes to this bug.